Table of Contents

Introduction ......................................................................................................................... vii
1. Notation Conventions ..................................................................................................... vii
2. Recent changes to this manual ....................................................................................... viii
I. Getting started .................................................................................................................. 9
   1. Installation .................................................................................................................. 11
   2. Selecting a user interface language ............................................................................. 12
   3. Consulting the manual ............................................................................................... 13
II. USER’S GUIDE .............................................................................................................. 14
   4. ELAN documents ........................................................................................................ 15
      4.1. Basic Information: Media Files and Annotation Files ........................................... 15
      4.2. How to manage documents .................................................................................. 16
         4.2.1. Creating a new document .............................................................................. 17
         4.2.2. Synchronizing video files .............................................................................. 18
         4.2.3. Opening an existing document ...................................................................... 21
         4.2.4. Re-open recently accessed files ..................................................................... 22
         4.2.5. Switching between multiple files ................................................................... 22
         4.2.6. Saving a document ....................................................................................... 23
         4.2.7. Saving a selection as .eaf file ....................................................................... 23
         4.2.8. Merging transcriptions .................................................................................. 24
         4.2.9. Saving a template ......................................................................................... 26
         4.2.10. Changing the links to media files ................................................................. 27
         4.2.11. Creating automatic backups ....................................................................... 28
         4.2.12. Printing ......................................................................................................... 29
         4.2.13. Configuring the page settings (page setup) .................................................... 29
         4.2.14. Previewing the printed pages ....................................................................... 30
         4.2.15. Importing Transcriber files .......................................................................... 35
         4.2.16. Importing a CHAT file ................................................................................. 35
         4.2.17. Importing a document from Shoebox ............................................................ 35
         4.2.18. Importing CSV / Tab-delimited Text Files ..................................................... 43
         4.2.19. Importing a Praat TextGrid file .................................................................... 46
         4.2.20. Exporting a document to Shoebox ................................................................. 47
         4.2.21. Exporting a document to Toolbox (UTF-8) .................................................... 50
         4.2.22. Exporting a document as a tab-delimited text file ....................................... 53
         4.2.23. Exporting Tiger XML .................................................................................. 56
         4.2.24. Exporting CHAT files ................................................................................... 56
         4.2.25. Exporting traditional transcript files .............................................................. 57
         4.2.26. Exporting a Praat TextGrid file .................................................................... 59
         4.2.27. Exporting an alphabetical list of word ........................................................... 59
         4.2.28. Exporting a part of a clip .............................................................................. 59
         4.2.29. Exporting a SMIL clip .................................................................................. 59
         4.2.30. Exporting to QuickTime Text ...................................................................... 60
         4.2.31. Exporting to Subtitle Text ............................................................................ 60
         4.2.32. Exporting ELAN’s document view ................................................................. 61
         4.2.33. Exporting to interlinear text ......................................................................... 62
         4.2.34. Exporting to HTML ..................................................................................... 63
         4.2.35. Exporting Multiple Files .............................................................................. 63
         4.2.36. Opening a wave file in Praat ........................................................................ 64
         4.2.37. Exporting a selection to a wave file with Praat ............................................ 65
         4.2.38. Closing a file ................................................................................................ 65
         4.2.39. Exiting ELAN .............................................................................................. 65
      4.3. Screen display and navigation through a document ................................................ 66
         4.3.1. Basic Information: The ELAN window ............................................................ 66
         4.3.2. The Video Viewer .......................................................................................... 67
         4.3.3. The Annotation Density Viewer ...................................................................... 69
         4.3.4. The Waveform Viewer .................................................................................. 70
ELAN - Linguistic Annotator

4.3.5. The Subtitle Viewer ................................................................. 71
4.3.6. The Grid Viewer ................................................................. 72
4.3.7. The Text Viewer ................................................................. 73
4.3.8. The Timeline Viewer and the Interlinear Viewer ...................... 74
4.3.9. The Timeseries Viewer ......................................................... 77
4.3.10. The Menu options .............................................................. 81
4.3.11. The Media Player options .................................................. 82
4.3.12. The color coding .............................................................. 84
4.3.13. Increasing/decreasing the size of the ELAN window ................. 85
4.3.14. Switching Viewers on/off ................................................... 85
4.3.15. Increasing/decreasing the size of Viewers ................................ 85
4.3.16. Switching tiers on/off ....................................................... 86
4.3.17. Rearranging the order of tiers ............................................ 87
4.3.18. Sorting tiers ......................................................................... 88
4.3.19. Changing the time zoom ...................................................... 88
4.3.20. Changing the vertical (intensity) zoom ................................... 89
4.3.21. Changing the font size ......................................................... 90
4.3.22. Font Browser ........................................................................ 91
4.3.23. Editing preferences ............................................................ 92
4.3.24. Importing and exporting preferences .................................... 94
4.4. How to navigate through a document ......................................... 94
4.4.1. Accessing points in time ....................................................... 94
4.4.2. Going to the borders of a selection ....................................... 96
4.4.3. Jumping step by step through a document ............................. 96
4.4.4. Viewing a list of annotations within one tier (Grid Viewer) ....... 97
4.4.5. Jumping from annotation to annotation (Interlinear Viewer) .... 100
4.5. How to play a document ........................................................ 100
4.5.1. Playing a document ............................................................ 101
4.5.2. Playing a selection ............................................................. 101
4.5.3. Playing around a selection .................................................. 102
4.5.4. Playing in slow motion ....................................................... 102
4.5.5. Changing playback rate and volume via the keyboard ............. 103
5. Annotations .................................................................................. 104
5.1. Basic Information: Annotations, tiers and linguistic types ............ 104
5.2. Data categories .......................................................................... 108
5.3. How to define a linguistic type .................................................. 110
5.3.1. Adding new linguistic types .................................................. 110
5.3.2. Creating linguistic types ..................................................... 111
5.3.3. Changing linguistic types .................................................... 112
5.3.4. Deleting linguistic types ..................................................... 112
5.3.5. Importing linguistic types ................................................... 113
5.3.6. Associating a linguistic type with a Data Category .................. 114
5.4. How to define a tier and its attributes ....................................... 114
5.4.1. Adding new tiers ............................................................... 114
5.4.2. Importing tiers ................................................................. 116
5.4.3. Changing tier attributes ..................................................... 117
5.4.4. Deleting tiers ...................................................................... 120
5.4.5. Changing the parent of a tier ............................................... 123
5.5. Controlled Vocabularies ............................................................ 124
5.5.1. The creation of a CV .......................................................... 124
5.5.2. Associating a CV entry with a Data Category ......................... 125
5.5.3. Importing an existing CV ................................................... 126
5.5.4. Exporting a CV ................................................................. 127
5.5.5. Using CVs .......................................................................... 127
5.5.6. Associating a linguistic type with Controlled Vocabularies ..... 128
5.6. How to make a selection .......................................................... 128
5.6.1. Making a selection on an independent tier ............................. 128
5.6.2. Using the selection controls ............................................... 131
6. Searching

6.1. Searching in a single annotation file

6.1.1. Advanced searching: an example

6.2. Displaying search results

6.2.1. The search history

6.2.2. Refining a search

6.2.3. Saving and loading queries

6.2.4. Exporting the search results

6.2.5. Search and replace

6.3. Jumping from the search results to annotations

6.4. Searching through multiple annotation files

6.5. Structured search through multiple annotation files

6.5.1. Substring Search Tab

6.5.2. Single Layer Search tab

6.5.3. Multiple Layer Search tab

7. Reference guide

7.1. The mouse options

7.1.1. Resizing Viewers

7.1.2. Rearranging the order of tiers

7.1.3. Make a tier the active tier

7.1.4. Accessing points in time

7.1.5. Playing a document

7.1.6. Making a selection

7.1.7. Adding/modifying an annotation

7.2. The shortcut keys
Introduction

ELAN (EUDICO Linguistic Annotator) is an annotation tool that allows you to create, edit, visualize and search annotations for video and audio data. It was developed at the Max Planck Institute for Psycholinguistics, Nijmegen, The Netherlands, with the aim to provide a sound technological basis for the annotation and exploitation of multi-media recordings. ELAN is specifically designed for the analysis of language, sign language, and gesture, but it can be used by everybody who works with media corpora, i.e., with video and/or audio data, for purposes of annotation, analysis and documentation.

ELAN supports:

- display a speech and/or video signals, together with their annotations;
- time linking of annotations to media streams;
- linking of annotations to other annotations;
- unlimited number of annotation tiers as defined by the users;
- different character sets;
- export as tab-delimited text files;
- im- and export between ELAN and Shoebox;
- search options.

This manual helps you to understand and use the features of ELAN.

Part I explains the installation process.

Part II is the user's guide. It is organized around the following four topics:

- ELAN documents
- The screen display and the navigation through a document.
- Annotations.
- Search Options.

For each topic, basic information is given. Following that, the use of features is explained in a step by step way. It is recommended that you read the relevant chapter before starting to work with your own data.

Part III is the reference guide, i.e., it provides brief information on the following topics: mouse options, menu items, and shortcut keys. In addition, the key concepts of ELAN are defined.

An overview of the differences between the succeeding versions of ELAN can be found online via: http://www.lat-mpi.eu/tools/elan/release-notes.html.

1. Notation Conventions

The following notation conventions are used:

- Menu items, icons and screen displays are written in the font sans-serif.
- (Shortcut) keys are written in SMALL CAPS.
2. Recent changes to this manual

2007-12-10: general update for version 3.3.0, among others the options for exporting ELAN data are expanded.

2007-10-04: general update for version 3.2.0, among others the structured search through multiple annotation files. This version of the manual is the first to be made from Docbook source to enable easy generation of PDF and HTML.

2007-03-27: some cross-references have been corrected.


2007-02-20: references to sections are corrected, new screenshots, keyboard shortcuts updated, a lot of small corrections.

2007-02-08: general update for version 3.0, among others the new search facilities were added.
Part I. Getting started
# Table of Contents

1. Installation .................................................................................................................. 11
2. Selecting a user interface language ............................................................................. 12
3. Consulting the manual ............................................................................................... 13
Chapter 1. Installation

To install ELAN on your computer, go to http://www.lat-mpi.eu/tools/elan/ and follow the instructions. On this webpage, you will also find information about software and hardware requirements.
Chapter 2. Selecting a user interface language

Once ELAN has been started, you can change the language of the user interface at any time. To achieve this, choose Options > Language and select one of the available languages.

**Note**

The selected Language does not influence the content of the produced or edited *.eaf files in any way.

At present Catalan, Dutch, English, French, German, Portuguese, Spanish and Swedish language modules are available. However, new languages can be easily added. If you want to provide a translation for a different language, please contact the ELAN development team.

Alternatively, you can immediately incorporate a new translation as follows. In the directory locale in the directory where ELAN is installed, you will find the files ElanLanguage.properties and SearchLanguage.properties. These files can be used as a basis for your translation. Copy the files to the directory .elan_data (Linux and Windows) or Library/Preferences/ELAN (on Mac OS) in your home directory and simply edit the entries in the files. To view the result of the translation, click Options > Language and select Custom.
Chapter 3. Consulting the manual

This manual is available in three different formats:

- Java Help: via Help -> Help Contents... in the ELAN window. The help files are searchable.
Part II. USER'S GUIDE

This part of the manual contains the user’s guide. It is organized as follows:

- ELAN documents (see Chapter 4)
- Screen display and navigation through a document (see Section 4.3)
- Annotations (see Chapter 5)
- Search Options (see Chapter 6)

It is recommended that you read the relevant section before starting to work with your own data.
Chapter 4. ELAN documents

4.1. Basic Information: Media Files and Annotation Files

Every ELAN project consists of at least two files: one (or more) media file(s), and one annotation file.

1. One (or more) media file(s):
   - 0 or more video file(s) (e.g. *.mpg, *.mov)
   - and/or one audio file (*.wav)

The video file allows you to view the video and listen to the sound. If you want to view the waveform as well, you need to create an additional *.wav file through a conversion program that converts the audio data from one *.mp(e)g file into a *.wav format. In the case of multiple video files, the audio of the first selected video file is played. The kind and number of supported video formats depend upon the media framework you are using. If your media framework supports a format, the same goes for ELAN.

The following media frameworks are known to work:
   - Windows (in order of preference, DirectX being the best solution):
     - DirectX/DirectShow (Windows Media Player)
     - QuickTime
     - JMF (Java Media Framework)
   - MacOS: QuickTime
   - Linux: JMF

Note

- For *.mov files (i.e., Cinepak-Quicktime-Movies) it is important that these are self-contained files, i.e., the video information needs to be contained within the *.mov file itself. If this is not the case, ELAN will not be able to display the file.
- Unlike other media files, the playback rate of Windows Media Audio (WMA) files cannot be altered.

2. One annotation file:
   - an annotation file created by ELAN (*.eaf, “EUDICO Annotation Format”)
   - or an imported annotation file. The following formats can be imported: Shoebox/Toolbox files (with the extension *.txt)
     - CHAT files (*.cha)
     - Transcriber files (*.trs)

All information (e.g., the tier setup, the time alignment, the annotations) is saved to the annotation file only – never to the media file(s).
Note

Take care when editing a media file. Afterwards you probably will want to resynchronize its alignment with the corresponding the annotations, as described in Section 4.2.2.

Although it’s not compulsory it is a good practice to use a common name for media files and the annotation file. So, it is recommended to use a.eaf next to a.mpg and a.wav.

Imported Shoebox files (*.txt) also do not need to have the same name as their media files, and they can be located in different directories. All imported files can alternatively be saved as ELAN files (*.eaf).

All annotation files (*.eaf) can be exported as text, Shoebox/Toolbox and CHAT files.

4.2. How to manage documents

To start ELAN, do the following:

1. Double-click on the ELAN icon (on your desktop, or contained within the Java Web Start icon on your desktop).

   The start dialog window is displayed, asking you what kind of document you want to open.

2. Click on the File menu (see Figure 4.1)

   The File menu supports the following options:

   • New (Section 4.2.1)
   • Open (Section 4.2.3)
   • Import (Section 4.2.15, Section 4.2.16, Section 4.2.17 and Section 4.2.19)
   • Exit (Section 4.2.39)

   Figure 4.1. File menu

3. Click on:

   • Open... in case there is an ELAN file (*.eaf) (Section 4.2.3)
   • New... in case there is a media file (e.g. *.mpg, *.wav), but no annotation file (*.eaf, *.txt) (Section 4.2.1).
• Import > Shoebox file... (Section 4.2.17)
• Import > CHAT file... (Section 4.2.16)
• Import > Transcriber file... (Section 4.2.15)
• Import > Praat TextGrid file... (Section 4.2.19)

Different dialog windows appear and prompt you to enter the names and locations of the different files. Then the ELAN window appears and displays the selected files.

Once you have started ELAN, use the File menu to open, create or import a second document.

4.2.1. Creating a new document

In case there is a media file but no annotation file (*.eaf, *.txt, *.trs), click on New in the File menu. The New Transcription dialog window (see Figure 4.2) will be displayed, e.g.:

Figure 4.2. The New Transcription dialog window: media

Do the following:

1. Click on the Look in pull down box and browse to the directory that contains the media files
2. If you want to use media files of another type (e.g. QuickTime *.mov) then select All Files in the Files of type dropdown menu. If a media type is supported depends on your software configuration.
3. Double-click on the media file (*.mpg/*.mov, *.wav, etc.) to select it. It appears now in the rightmost box. Alternatively, you can click on the media file name and click afterwards on the >> button.
4. If you want to use a predefined set of tiers (a template), select the Template radio button and choose the template (i.e. *.etf) to be used:
5. Beside media files on disk you can also add a streaming file of Real Time Streaming Protocol (RTSP). Click on Add Streaming File... and enter the url of the streaming media. Click on OK.

6. Click OK to open the new annotation document; otherwise click Cancel to exit the dialog window without creating a new file.

An ELAN window containing the new document appears.

### 4.2.2. Synchronizing video files

Sometimes one has two or more video files of the same recorded scene, e.g. when 2 different cameras were used. In that case it may happen that both recordings don’t start exactly at the same moment. In order to fix this, one should synchronize the videos. This can be done as follows:

1. Open the new document with the 2 (or more) video files.

2. Select the pull down menu Options > Media Synchronization Mode

3. Make a choice about how the time codes should be displayed:
   a. Absolute offsets: for every video its own timing is being shown.
   b. Relative offsets: the video of player 1 is appointed to be the “master”, i.e. the time position of the other videos will be expressed as to the starting point of this file, which starts at 00:00:00.000.

4. Select the radio button player 1. You can now choose a moment in the video which is easy to calibrate (some clear anchor point, in both of the videos). For instructions how to navigate through the video file, see Section 4.4.
Figure 4.4. Synchronizing video files: Offset of player 1

5. Now select player 2 and go to the same calibration point.

**Note**

See Section 4.2.10 for changing the order of the videos, i.e. the order of appearing in Player 1, Player 2, etc.
6. Finally, choose Apply current offset. By selecting the play button both videos will be played together now, so you can check if the synchronization between them is correct. If not, please repeat step 3-5 until the result is satisfactory.

7. Leave the synchronization mode by selecting Options > Annotation Mode. Now you are ready to start entering annotations.

8. By double clicking on a video, it will be placed in the leftmost video window (which is also the biggest one in case there are 3 videos).

**Note**

If you changed the media file synchronization of a file that already is annotated, you might want to move the annotation units all together to the right (later, positive value) or to the left (earlier, negative value) on the time axis. This can be done using the Annotation > Shift all annotations … menu:
4.2.3. Opening an existing document

In case there is a media file (*.mpg/*.mov/*.wav) and an ELAN file (*.eaf), click Open in the File menu.

The Open dialog window is displayed:

Do the following:
1. Browse to the directory that contains the ELAN file (*.eaf).
2. Double-click on the annotation file to open it.

An ELAN window containing the document appears.

You can only open files of the EUDICO annotation format (*.eaf). If you try to open a file of a different format, the following error message appears:
Figure 4.8. Error message: no eaf file

Note

If ELAN cannot find the associated media files (*.mpg, *.mpeg, *.mov, *.wav), it will check if these files exist in the directory of the EAF-file. If they are still not found there, it will ask you where the media files are located:

Figure 4.9. Locate media file

4.2.4. Re-open recently accessed files

A convenient way to open a file that you have previously been working with is the File > Open Recent File dropdown-menu.

4.2.5. Switching between multiple files

If you open up several annotation files, you can get an overview of the currently opened documents under the Window dropdown-menu:
4.2.6. Saving a document

All documents can be saved as ELAN files (*.eaf, “EUDICO Annotation Format”). This includes documents that were created by ELAN itself (see Section 4.2.1) as well as documents that were imported into ELAN from Shoebox/Toolbox, CHAT or Transcriber (see Section 4.2.17, Section 4.2.16 or Section 4.2.15). To save a document as an ELAN file:

1. Either use the menu options:
   a. Click on File menu.
   b. Click on Save or Save as.
2. Or use the shortcut key CTRL+S.

**Note**

Apart from the *.eaf file, a *.pfs file will be written as well. This file contains user and document specific settings like the font size used to display text. The *.pfs file can however be safely removed as it does not contain any annotation data.

4.2.7. Saving a selection as .eaf file

Apart from saving a whole document you can also store the contents of a certain time span to an .eaf file, using the following steps:

![Figure 4.10. Windows dropdown-menu](image)
4.2.8. Merging transcriptions

Under some circumstances it might be useful to combine the contents of two separate transcription files into a single one. To achieve this, follow these steps:

1. Choose File > Merge Transcriptions

2. A dialog window appears:
3. If one of the files to be merged is currently opened, select Use current transcription. Otherwise choose Browse… and select the first eaf-file.

4. Choose the second file. If there are common tiers in both files and you want those of the second file to overwrite those of the first, make sure Allow existing annotations to be overwritten is checked.

5. Enter a file name for the result of the merge operation.

6. Click on Next

7. Select the tiers of the second source file that you want to merge with the first file and click on Finish
8. When the merge procedure has been finished you can choose whether to open the result immediately in new ELAN window:

Figure 4.14. Open new transcription

4.2.9. Saving a template

A template offers the possibility to reuse the same document setup for more than one media file. This includes:

- linguistic types (see Section 5.3)
• controlled vocabulary (see Section 5.5.6)
• tiers (see Section 5.4)

Saving a template is done as follows:

1. Click on File menu.
2. Click on Save as Template…
3. Choose a file name ending in .etf
4. Click on Save

See Section 4.2.1 for a instructions on using a template.

4.2.10. Changing the links to media files

As from ELAN version 2.4, the possibility exists to explicitly change the links to media files that are linked from an *.eaf file. This option can be handy if e.g. you have moved media files to another location after the last time you edited an ELAN file.

Activating the Linked Files dialog (via Edit > Linked files…) will get you the following screen:

Figure 4.15. Linked files dialog window

The following options are available on the Linked Media Files tab:

• Add…: add a link to a new media file to the current *.eaf file
• Remove: remove the selected media file
• Update…: specify a new location of the selected file. Especially useful if the checkbox Status is not marked. The latter indicates the media file could not be found while the ELAN file was opened (e.g. because the media files was moved).
• Set Master Media: make the selected media file the Master Media
• **Set Extracted from…**: indicate that a sound file has been extracted from a video file

• **Up/Down**: moves a file up/down in the linked file list. The file on top automatically becomes the Master Media file. The audio file on the highest location is displayed in the Waveform Viewer.

The Linked Secondary Files tab shows files that are linked as secondary files. In particular files that contain data that to be displayed by the Timeseries viewer (see Section 4.3.9) is found here, but other files may be linked as well. The following options are available:

• **Add…**: add a link to a new file to the current *.eaf* file

• **Remove**: remove the selected file

• **Update…**: specify a new location of the selected file. Especially useful if the checkbox **Status** is not marked. The latter indicates the file could not be found while the ELAN file was opened (e.g. because the media files was moved).

• **Set Associated With…**: associate the file with another linked file.

### 4.2.11. Creating automatic backups

ELAN allows you to create automatic backup copies. To create backups, do the following:

1. Click on **File** menu.
2. Go to **Automatic backup**.
3. Click on the time interval after which ELAN should create the backup, e.g., after every 10 minutes.

**Figure 4.16. Automatic backup**
A checkmark appears next to the selected time interval. From now on ELAN will automatically create a backup copy, saving it with the extension *.*eaf.001. Before opening such a file, rename its extension to .eaf instead of .eaf.001

**Note**

Automatic backups can only be made *after a file has been saved!* If you did not save your file before, a warning window will be shown when the backup should be made for the first time, urging you to save the file first.

### 4.2.12. Printing

1. Printing from within ELAN can be achieved by selecting the File > Print menu.

2. Then a standard print dialog is shown, choose OK to start printing.

**Figure 4.17. Printing**

![Printing Dialog]

**4.2.13. Configuring the page settings (page setup)**

Through File > Page setup you can alter the paper size and other settings of the pages to be printed.
4.2.14. Previewing the printed pages

The fine tuning of the print result can be done by opening the Print Preview window, which is accessible via the File > Print Preview menu.
Figure 4.19. Print preview

- Put a checkmark in front of all the tiers that should be printed.
- Arrange the order of the tiers with the buttons.
- The font size of the tiers can be adapted by clicking on the Font Sizes button. A new window will appear:
After choosing the desired font size, click on the **Apply Changes** button in the Print Preview window. After that, the changes will appear:
Figure 4.21. Print preview after changes

- **Width**: specify the width of the printed area (in pixels). This value can only be changed by selecting a paper format in the Page setup dialog (see Section 4.2.13).
- **Height**: enter the height of the printed area (in pixels). If you leave this empty, the default height will depend upon the selected paper size.
- **Wrap Blocks**:
- **No wrapping**: use 1 line for each tier, only usable for files that contain a small amount of annotations.

- **Within block**: wrap blocks, and continue with a new block on the same line if there is space left.

- **At block boundaries**: wrap blocks, and continue with a new block on the same line if there is space left and if the new block fits on that line.

- **Each block**: wrap blocks, and start on a new line if a block ends.

- Sort: specify in which order the blocks will appear. This is similar to the tier sorting function (see Section 4.3.18).

- Line spacing: amount of whitespace between the lines (default: 0 pixels)

- Block spacing: amount of whitespace between the blocks (default: 20 pixels)
4.2.15. Importing Transcriber files

The feature to import Transcriber annotation files into ELAN works as follows:

1. Choose File > Import > Transcriber File …
2. Select the transcriber file (*.trs) and click on Open
3. If the associated sound file cannot be found, a dialog will be shown asking you to locate it. When this request is cancelled, one can choose to open the annotation file without the sound, or to stop the whole import process.

The transcriber tiers will be mapped on the ELAN equivalents:

- Section becomes a independent tier and turn becomes a referring tier of section (see also Section 5.1).
- Events are embedded into the annotation text.

4.2.16. Importing a CHAT file

It is possible to import CHAT files (used in e.g. the Childes project) in ELAN:

1. Select File > Import > CHAT File …
2. Select the Chat file
3. Click on Open

Some remarks about this import feature:

- supported are old CHAT files and CHAT-UTF8, not XML CHAT
- existing media alignment in %snd tiers is maintained in ELAN:
  - when no media alignment is present at all, each CHAT utterance gets a default interval of 1 second assigned
  - when partial media alignment is present, the time interval is equally distributed over preceding unaligned utterances
  - overlapping utterances of the same participant are corrected as good as possible
  - CHAT dependent tier names are mapped to ELAN Linguistic Types
  - ELAN tier names are either CHAT participant labels or CHAT tier names, followed by '@participantName'

Remaining issues:

- '<' and '>' characters in CHAT cause parsing errors when the imported file is saved as EAF file

4.2.17. Importing a document from Shoebox

ELAN supports the import of documents from Shoebox, thereby allowing you to link transcribed and/or interlinearized documents to the time axis of media files. In order to import from Shoebox, you need at least the following two files:

1From here on, every appearance of Shoebox can also be read as Toolbox, i.e. the newer version of what was formerly known as Shoebox.
• the Shoebox file (*.txt);

• the media file(s) (*.mpg/*.mov, *.wav);

• Optionally the corresponding Shoebox database type file (*.typ). If this is not available, one has to provide a list with field markers (= tier names).

**Note**

If you do not know the Shoebox database type file, do the following:

1. Open the Shoebox *.txt file in Shoebox. Make sure it is the active window (click on it to activate it).

2. Click on Database menu.

3. Click on Properties …. The Database Type Properties dialog box appears. The name of the database type is displayed in the header, e.g.:

4. Locate the directory of the database type file (e.g., “texts.typ” in the above illustration). It is probably located in the directory “My Shoebox Settings”.

**Importing shoebox files with a TYP file**

To import a Shoebox file into ELAN, do the following:

1. Click on File > Import > Shoebox File. The Import Shoebox dialog box appears.

2. Specify the name and directory of the two files, e.g.:
3. Like *.eaf documents, the Shoebox file and the media file(s) do not necessarily need to have the same name, and they do not need to be in the same directory (see Section 4.1).

If the shoebox file contains both aligned (i.e. containing time information) and non-aligned records, the aligned ones will maintain the timing, whereas the location of the non-aligned records will be interpolated automatically.

4. Click OK to import the file; otherwise click Cancel to exit the dialog box without importing the file.

An ELAN window containing the imported Shoebox file appears.

**Importing shoebox files without a TYP file**

Instead of using a shoebox *.typ file, there is also an option in ELAN to define the field markers yourself when importing a shoebox file.

1. select the Set field markers and click on the button in the import dialog:

   **Figure 4.24. Import Shoebox file without TYP file**

2. Now fill in a field marker as used in the shoebox *.txt file
3. Optionally select a parent marker (see Section 5.1)

4. Optionally select a stereotype (symbolic subdivision or association, see Section 5.1)

5. Choose a character set (Latin-1, SIL IPA or UTF-8) for the tier

6. Click on Add.

7. Repeat step 2-6 for all field markers.

8. If the selected marker designates a participant, check the Participant Marker checkbox. If you don’t want the selected marker to be imported, tick Exclude from import.

9. Finally choose Close and click on OK in the import shoebox file dialog

**Figure 4.25. Set Shoebox/Toolbox field markers**

![Set Shoebox/Toolbox Field Markers](image)

**Loading and storing Markers**

Once you have manually created a set of field makers, you might want to reuse them later on. ELAN provides support for this:

- To save a set of field markers, select the Store Markers… button. This will display a save dialog. Enter a filename, and press save.

- The same way you can open a stored field marker set by clicking on Load Markers…
Figure 4.26. Store markers

Connecting the transcription to a media file

Once the import has succeeded, you can add a reference to a media file via the Edit > Linked Files… menu, as described in Section 4.2.10. If the imported shoebox file was exported from ELAN before, you won’t need to establish the link to the media file(s) again, as in that case the location information is stored in the file.

About the import process

ELAN imports Shoebox files according to the following conventions:

1. The Shoebox field markers are imported as ELAN tiers. The tier label is identical to that of the field marker, except for the added extension @‘Speaker-ID’.

   This addition is necessary because ELAN and Shoebox differ in how they code information about multiple speakers:

   • In ELAN, each speaker is coded on a separate tier.

   • In Shoebox, all speakers are coded using the same field, and their identity is specified in a separate field.
When importing texts by multiple speakers, ELAN splits each Shoebox field into several ELAN tiers (one for each speaker) and adds the speaker-ID to the tier label.

If speaker information is not specified in the Shoebox file, the extension @unknown is added.

The following screenshot illustrates how ELAN treats texts by multiple speakers:
Note that ELAN can only read speaker information if:

- A marker is defined as a Participant marker in the Set field marker dialog (see Importing shoebox files without a TYP file above), or if:

- Or if it is coded in a Shoebox field labeled \EUDICOOp or \ELANParticipant (see illustration above). If this field is not present, or if speaker information is coded in a different field, ELAN will assume that there is only one speaker. I.e., if you have multiple speakers and if you want ELAN to assign them to separate tiers, do the following:

  1. For every Shoebox record, add the field marker \EUDICOOp.
  2. For every Shoebox record, enter the relevant speaker-ID into this field.

  **Note**

  When the file is exported back to Shoebox (see Section 4.2.20), the extension @‘Speaker-ID’ is automatically dropped from the field marker, and the Shoebox records are sorted according to their record marker (e.g., in the above illustration, “test 001” is sorted before “test 002” etc.)

  3. Based on the information contained in the Shoebox database type file, the tiers are brought into a hierarchical relationship and are assigned to linguistic types (see Section 5.1 for details of tier hierarchies and linguistic types). For every tier name a corresponding linguistic type with the same name is created. All of these linguistic types are connected with a stereotype in such a way that it fits with the original shoebox structure.

   - The Shoebox record marker is assigned to the stereotype None, i.e., it is an independent, time-alignable parent tier.
   - The transcription and parsing fields of Shoebox are assigned to the stereotype Symbolic Subdivision, i.e., they are referring tiers that can be subdivided into smaller units.
   - All other fields are assigned to the stereotype Symbolic Association, i.e., they are referring tiers that cannot be subdivided into smaller units.

  If you define the markers yourself, then there also is the possibility to choose the Time Subdivision stereotype. For example:
4. All SIL IPA characters are converted into Unicode characters during import. If you export the file back into Shoebox (see Section 4.2.20), the Unicode characters will be converted back into SIL IPA characters.

5. Initially, unless it had the time code information, the imported Shoebox file does not contain information about timing. Instead, ELAN automatically assigns each Shoebox record to a three second time interval, as in the following illustration:

**Figure 4.30. Fixed time intervals**

The time alignment has to be done manually for each Shoebox record. Do the following:

1. Activate the Bulldozer mode: Click on Options > Propagate Time Changes > Bulldozer Mode (see Section 5.6.7 for the three available modes).
Note

If you do not activate the Bulldozer mode, you will inadvertently overwrite and thereby delete existing annotations. Make sure that Bulldozer Mode is enabled in the Options > Propagate Time Changes menu.

2. Click on the first annotation on the parent tier (i.e., the first Shoebox record). It appears in a dark blue frame.

3. Modify the boundaries of that annotation, so that they are aligned with the correct time interval (see Section 5.6.6 for ways of modifying boundaries).

4. Press **CTRL+ENTER** to apply the new time interval.
   
The parent annotation (together with all its referring annotations) is assigned to the new time interval. All other parent annotations are moved to the right.

5. Repeat steps 2 to 4 for each parent annotation.

The following screenshot illustrates steps 1 to 4:

Figure 4.31. Time alignment

After you have done the time-alignment, you can export the file back to Shoebox – in this case, the time code information will be kept (see Section 4.2.20). If you then re-import the file back into ELAN, ELAN automatically assigns the Shoebox records to their correct time intervals.

An imported Shoebox file can be saved as an ELAN file (see Section 4.2.4), exported back into Shoebox (see Section 4.2.20), or exported as a tab-delimited text (see Section 4.2.22).

### 4.2.18. Importing CSV / Tab-delimited Text Files

A CSV (Comma Separated Values) or Tab-delimited Text file is a text file in which one can identify rows and columns. Rows are represented by the lines in the file and the columns are created by separating the values on each line by a specific character, like a comma or a tab. CSV or Tab-delimited Text files can be compared to spreadsheets like the ones in Microsoft Excel in that they also have rows and columns. Note that .csv files can be created by Excel.

Take a look at Figure 4.32. The first row represents the event of a person saying 'so from here'. The first value (as well as the first column of the complete file) represents the tier name, the second and third represent
begin time in different formats, the fourth and fifth represent the end time, the sixth an seventh represent the duration and the last value represents the annotation.

**Figure 4.32. Tab-delimited Text**

<table>
<thead>
<tr>
<th>Tier</th>
<th>Begin time</th>
<th>End time</th>
<th>Duration</th>
<th>Annotation</th>
</tr>
</thead>
<tbody>
<tr>
<td>k-Spch</td>
<td>00:00:00.280</td>
<td>00:00:00.280</td>
<td>0.28</td>
<td>go from here.</td>
</tr>
<tr>
<td>k-Spch</td>
<td>00:00:04.040</td>
<td>00:00:04.040</td>
<td>4.04</td>
<td>yeah</td>
</tr>
<tr>
<td>k-Spch</td>
<td>00:00:10.000</td>
<td>00:00:10.000</td>
<td>10.06</td>
<td></td>
</tr>
<tr>
<td>k-Spch</td>
<td>00:00:14.320</td>
<td>00:00:14.320</td>
<td>14.32</td>
<td></td>
</tr>
</tbody>
</table>

You are able to import CSV or Tab-delimited Text files in ELAN: File > Import > CSV / Tab-delimited Text File. In the dialog window browse to and select a file that contains CSV or Tab-delimited data and click Open.

The second dialog window contains two sections (see Figure 4.33). The upper section shows a sample table containing data from the selected file. Both rows and columns are numbered. The lower section enables you to specify which columns to include and what data type they represent. This means that the format of the files is flexible: it is not prescribed what data is expected nor how it is formatted. The numbers of the columns in the Import Options section correspond to the numbers of the columns in the sample table. The data types you can select are:

- Annotation
- Tier
- Begin time
- End time
- Duration

Select at least one column with data type ‘Annotation’. If you select a column for begin time, end time and duration, the latter will be ignored in the import process.
Figure 4.33. Import CSV / Tab-delimited Text

The option Specify first row of data enables you to exclude a header by excluding the first few lines. The option Specify delimiter lets you specify the delimiter if Elan did not guess the correct delimiter. The delimiters supported by Elan are comma, tab, colon and semi-colon.

If you enable the option Default annotation duration Elan creates all annotations from the selected file with durations equal to the number of milliseconds specified. This option works only if there is no time data or only the begin or end times.

Finally click OK to import the data. A new transcription document is created with the imported annotations as its contents.

Another example

To demonstrate that the format of the imported file can be flexible, take a look at the following tab-delimited text:
Figure 4.34. Tab-delimited text, different orientation

<table>
<thead>
<tr>
<th>E-Spch</th>
<th>W-Spch</th>
</tr>
</thead>
<tbody>
<tr>
<td>so from here.</td>
<td>so you go out of the Institute to the Saint Anna Street.</td>
</tr>
<tr>
<td>yeah</td>
<td>and then you go the other, Saint Anna Street to this to the center of the town, to this big rotunde.</td>
</tr>
<tr>
<td>ja</td>
<td>and you follow then the sign Kieler</td>
</tr>
<tr>
<td></td>
<td>that's the orange single</td>
</tr>
</tbody>
</table>

In this example each column represents a tier with the tier names in the first row and the annotation in the other rows. This file can be imported by selecting the following import options:

Figure 4.35. Import CSV / Tab-delimited Text

Note that the Specify first row of data option is set to 2. As a consequence Elan starts importing annotations from row 2 instead of row 1. Furthermore, Elan tries to extract tier names from the first line of the file if the column they part of is specified as ‘annotation’. This results in this example in two tiers: K-Spch and W-Spch.

4.2.19. Importing a Praat TextGrid file

ELAN offers the possibility to import a Praat TextGrid file: click on File > Import > Praat TextGrid File.... In the dialog window that now appears, you can browse to the file you wish to import. You are also able
to include Praat PointTiers. When selecting this option, specify the default PointTiers annotation duration in milliseconds.

In addition to TextGrid files in the default encoding for the operating system, ELAN supports Praat TextGrid files with UTF-8 and UTF-16 encoding.

4.2.20. Exporting a document to Shoebox

All Shoebox files that were imported into ELAN (see Section 4.2.16) can be exported back into Shoebox. In this case, the time code information is kept.

To export a file into Shoebox, do the following:

1. Click on File menu.
2. Click on Export as > Shoebox file ....

   The Shoebox Export dialog box appears. Make a choice and click on OK to continue.
Figure 4.36. Shoebox Export dialog window

- By selecting **Wrap block** you can let ELAN wrap a whole block if one of the line in a block is longer than a specified number of character (default is 80 characters).

- By selecting **Add master media time offset to annotation times** you can add to the annotation times the time offset from the master media that originated from the synchronization of media files (see Section 4.2.2).

3. Specify the name and directory of the exported file, e.g.: 

   - **Use a Shoebox *.typ file to specify the DatabaseType name**
   - **Define the tiers and their properties yourself**
   - **Define field markers... Specify Shoebox database type**
   - **Use exactly the same name for the shoebox tiers as the ELAN tiers. Optionally generate an ELAN marker file automatically (useful to import the resulting shoebox file in ELAN again)**

- **Select the tiers that should be exported**

- **Use a Shoebox *.typ file to specify the DatabaseType name**
4. Click **Save** to export the file; otherwise click **Cancel** to exit the dialog box without exporting the file.

   The file is exported as a `.txt` file.

   If there already exists a file of the same name, ELAN will ask you whether or not it should overwrite the existing file, e.g.:

   **Figure 4.38. File Exists**

5. Open the exported file in Shoebox.

   It contains the following information:

   a. All tiers and annotations.

      Each ELAN parent annotation (including all its referring annotations) corresponds to one Shoebox record. E.g., in the illustration below, the ELAN parent annotation “Ligya-001” corresponds to the Shoebox record “Ligya-001”.

   b. The time code information for each parent annotation.
Each ELAN parent annotation (i.e., each Shoebox record) contains the additional field markers \ELANBegin and \ELANEEnd (i.e., the begin and end time of the parent annotation).

This timecode information allows you to import the Shoebox file back into ELAN, without having to manually re-align the file (see Section 4.2.17).

Figure 4.39. ELAN file and exported file

4.2.21. Exporting a document to Toolbox (UTF-8)

Similar to exporting a document to Shoebox (see Section 4.2.20) ELAN data can be exported to a Toolbox document with an UTF-8 encoding. This export provides more options for output customization.

To export a file into Toolbox, do the following:

1. Click on File menu.

2. Click on Export as > Toolbox File (UTF-8)...

The Toolbox Export dialog box appears:
Only the left part of ELAN tier names containing an @ are identified as tier markers for Toolbox. These markers form a block in the exported file. The right part of the ELAN tier names are identified as participant names. These are exported with the marker ELANParticipant (see also Figure 4.41).

If you use a Shoebox * .typ file to specify the Toolbox database type ELAN extracts the database type name from the first line of the type file (e.g. the database type name Text in \+DatabaseType Text) and puts it in the first line of the exported file (e.g. \\_sh v3.0 400 Text).

When there is only one root tier (tier without a parent tier) in the transcription (e.g. ref) this will be used as the record marker by default. When there are multiple root tiers "block" will be added as record marker. In both cases it is possible to specify a custom record marker instead.
Some options not touched up in Figure 4.40:

- By first selecting a tier and then selecting **Insert blank line after this marker** you insert a blank line after the selected marker every time the marker is printed in the exported file. The tier name is colored blue in the dialog box.

- By selecting **Wrap block** you can let ELAN wrap a whole block if one of the lines in a block is longer than a specified number of characters (default is 80 characters). A block in this context refers to the markers that are part of the interlinearization.

- When **Wrap blocks** is selected it is also possible to select **Wrap lines**. This applies to long marker lines that are not part of the interlinearization. There are 2 variants: when Wrap to next line is selected the line is split into 2 or more lines that immediately follow each other, regardless of their position in the record. When Wrap to end of block is selected everything beyond the first wrap is placed at the end of the record. Note that wrapped interlinearization blocks are grouped as much as possible.

- When **Include empty markers** is selected all markers will be printed in each record, whether there is content or not. When this option is not selected a marker will not be printed in a record when it has no content.

- By selecting **Add master media time offset to annotation times** you can add to the annotation times the time offset from the master media that originated from the synchronization of media files (see Section 4.2.2).

Make a choice and click on **OK** to continue.

3. Specify the name and directory of the exported file.

4. Click **Save** to export the file; otherwise click **Cancel** to exit the dialog box without exporting the file.

The file is exported as a *.txt* file.

If there already exists a file of the same name, ELAN will ask you whether or not it should overwrite the existing file.

5. Open the exported file in Toolbox.

It contains the following information:

- All tiers and annotations.

  Each ELAN parent annotation (including all its referring annotations) corresponds to one Toolbox record. E.g., in the illustration below, the ELAN parent annotation “CLLDCh3R02S01.001” corresponds to the Toolbox record “CLLDCh3R02S01.001”.

- The time code information for each parent annotation.

  Each ELAN parent annotation (i.e., each Toolbox record) contains the additional field markers \ELANBegin and \ELANEnd (i.e., the begin and end time of the parent annotation).

  This timecode information allows you to import the Toolbox file back into ELAN, without having to manually re-align the file (see Section 4.2.17).
4.2.22. Exporting a document as a tab-delimited text file

All documents can be exported into a tabular format for purposes of further analysis and/or printing. This includes documents that were created by ELAN itself (see Section 4.2.1 and Section 4.2.3) as well as documents that were imported into ELAN from Shoebox (see Section 4.2.17). Do the following:

1. Click on File menu.
2. Click on Export as > Tab-delimited Text ….

The Export as tab-delimited text dialog window is displayed, e.g.:
3. By default, ELAN exports all annotations, but it is possible to restrict the export process to selected annotations. The following three options are available:

   a. Export only those annotations that correspond to a selected time interval. Do the following:
      
      i. In the ELAN window, select the desired time interval (see Section 5.6.1).
      
      ii. In the Export as tab-delimited text dialog window, click in the box to the left of Restrict to selected time interval. A checkmark appears indicating that this option has been selected.

   b. Export only those annotations that are contained on particular tiers. Do the following:
      
      In the Export as tab-delimited text dialog window, select those tiers that you want to export. A checkmark appears next to any selected tier.

   c. Export only those annotations that (a) correspond to a particular time interval and (b) are contained on particular tiers. To do this, combine the two steps under (a) and (b) above.

4. By selecting Add master media time offset to annotation times you can add to the annotation times the time offset from the master media that originated from the synchronization of media files (see Section 4.2.2).

5. The option Separate column for each tier gives each tier its own column in the export file. Annotations that have the same begin time and the same end time are exported to the same row i.e. the same tab-delimited line.

6. Select the time markers you want to export (begin time, end time and/or duration of every annotation unit).

7. Choose the time format (hh:mm:ss.ms, ss.msec, milliseconds and/or SMPTE timecode)
If you choose the SMPTE (hh:mm:ss:ff) format, the selected video standard (PAL or NTSC) just indicates the way seconds and milliseconds are converted to frame numbers. This is independent of the actual video standard of the associated video(s).

8. Click **OK** to start the export process; otherwise click **Cancel** to exit the dialog box without exporting the annotations.

9. Finally you will see a save dialog window. In the Encoding drop down box a text encoding can be selected (either iso-latin, UTF-8 or UTF-16). Make an appropriate choice and click on **Save**.

Some Mac applications, like TextEdit, have difficulties to load UTF-8 encoded files. This is most noticeable for “special” characters, e.g. IPA. Using UTF-16 is recommended in that case.

A message appears to inform you that the file has been exported. The exported file has the extension *.txt*. The exported file contains the following information: begin time of each annotation, end time, total length, content, and tier. It can be opened with any program that can handle tab-delimited texts, e.g., Microsoft Excel.

Figure 4.43. Tab-delimited text
Note

Some versions of Excel seem to have problems importing tab-separated files (white rectangles are shown instead of the column borders). As a workaround you can open the text file first in a text editor (e.g. notepad) and copy and paste the content into Excel.

4.2.23. Exporting Tiger XML

If your ELAN annotations contain syntactic elements, it is possible to export these to Synpathy² (see http://www.lat-mpi.eu/tools/synpathy/). This function is available via File > Export as > Tiger-xml…

First select out of the candidate tiers the one you want to be exported. Afterwards, map the tiers onto the correct description ("word" or "pos"). Finally enter the name of the file (* .tig).

4.2.24. Exporting CHAT files

1. Choosing File > Export as > CHAT file … will give you the following screen:

Figure 4.44. Export Chat file

2. Fill in the necessary fields.

²Synpathy is a tool for annotating, analyzing, and graphically editing the syntactical structure of sentences (e.g. linguistically annotated text corpora), developed at the Max Planck Institute for Psycholinguistics. The application is based on the SyntaxViewer from the TIGER search project developed by the IMS (Institute für Maschinelle Sprachverarbeitung, University of Stuttgart).
Note

Chat labels must be preceded by * (for root tiers) or % (for dependent tiers). While root tiers have to contain exactly 3 characters, dependent tier names can have up to 7 characters.

3. Click on Export…

4. Fill in a chat file name and choose Save

4.2.25. Exporting traditional transcript files

In some situations a straight-forward list of the annotation units, one after another, can be handy. For that cause an export option to a “traditional transcript text” has been added to ELAN. In its simplest form it just will create a text file containing the successive annotations of several tiers, in chronological order. This feature can be found under File > Export as > Traditional Transcript Text....
As can be seen in one of the options enables you to include silences with a minimal duration. In the figure there is a silence of 0.2 seconds between 'yeah' on the tier K-Spch and 'and the you go the other...' on the tier W-Spch. The first annotation end at 00:00:04.400 seconds and the second begin at 00:00:04.600 seconds, resulting in a silence of 0.2 seconds. If this silence was shorter than the minimal silence duration entered in the export dialog window (20 ms in the figure), the silence will not be included in the exported file.
4.2.26. Exporting a Praat TextGrid file

When you wish to work with your annotations in Praat, ELAN enables you to export your annotation to a Praat TextGrid. To do this, click File > Export as > Praat TextGrid.... In the dialog window that appears you can select the tiers you wish to export and specify whether you want to restrict the output to the selected interval.

After clicking OK, you can enter a filename and select an encoding. In addition to TextGrid files in the default encoding for the operating system, ELAN supports Praat TextGrid files with UTF-8 and UTF-16 encoding. Finally click on Save.

4.2.27. Exporting an alphabetical list of words

Sometimes it can be very useful to have a alphabetical list of (unique) words from one or more tiers. ELAN offers a way to generate such lists. Go to File > Export as > List of Words ... and select the tiers from which you want to extract the words. The annotations of the selected tiers will be tokenized (split into words) using either a default set of delimiters or a user definable set. After selecting tiers (or better, deselecting unwanted tiers) you can click OK and choose a filename. Clicking Save will save the wordlist.

4.2.28. Exporting a part of a clip

When a command line tool for extracting clips from video files is installed Elan is able to use that tool. At this moment only M2-edit-cl3 from Mediaware Solutions is supported. If the edit tool is in the user path and a selection is made, there is a menu item to export a video clip of the current selection for each linked video. In that case, follow these steps:

1. Select the part of the video(s) you want to export as (a) clip(s)
2. Choose File > Export As > Media Clip...
3. Enter a filename and press Save

4.2.29. Exporting a SMIL clip

ELAN supports export to SMIL4-compliant clips. With a suitable player this enables you to view media files and the associated annotations as a subtitled movie.

1. Select the File > Export As > SMIL... menu. This will bring up this dialog box:

---

4For a description of this standard and players see http://www.w3.org/AudioVideo/
2. Select the tiers you want to export. Keep CTRL pressed and click to select multiple tiers, press Shift and click to select multiple successive tiers.

3. Check **Restrict to selected time interval** if you only want to export the current selection. Otherwise the whole media file and associated annotations will be exported.

4. Click on the suggested filename to change the location where the SMIL clip will be saved.

5. Choose **OK** to export the clip.

### 4.2.30. Exporting to QuickTime Text

Another format you can export to from ELAN is QuickTime subtitle Text. To do this, go to **File > Export As > QuickTime Text**. Select the tiers you want to be included in the subtitles. Optionally specify the following options:

- **Restrict to selected time interval**: restrict the subtitles to the current selection.

- **Add master media time offset to annotation times**: add to the annotation times the time offset from the master media that originated from the synchonization of media files (see Section 4.2.2).

- **Minimal duration per subtitle (in ms.)**: specify the minimal display duration of a subtitle. For instance, if a annotation is only 0.3 seconds long, but you want to display a subtitle at least 0.5 seconds, enter 500 (ms).

- **Merge tiers into one QuickTime text file**: If not selected a separate text file will be generated for each tier.

Finally click on **OK**.

### 4.2.31. Exporting to Subtitle Text

Besides the QuickTime subtitle Text (see Section 4.2.30) there is another subtitle format ELAN can export annotations to: SubRip with file extension `.srt`. Click on **File > Export As > Subtitle Text** and select the tiers you want to include in the subtitle file. Specify whether the subtitles should be restricted to annotations in the selected time interval and if the master media time offset should be added to the annotations times.
The third option lets you specify the minimal display duration of a subtitle. For instance, if a annotation is only 0.3 seconds long, but you want to display a subtitle at least 0.5 seconds, enter 500 (ms).

**Figure 4.47. Export as Subtitles text**

![Export as Subtitles text](image)

After you have selected tiers and specified the options, click on **OK**. Enter a filename in the next window and click on **Save**.

### 4.2.32. Exporting ELAN’s document view

To export ELAN’s document view (i.e. to make a screenshot):

1. choose File > Export As > Image from Elan Window...
2. Enter a filename and an extension (*.jpg, *.jpeg or *.png)
3. click on **Save**.

**Note**

If you are using Windows, it sometimes happens that ELAN’s video window is black on the picture created using this function. This can be solved by temporary disabling the hardware video acceleration:

a. Right-click on the desktop
b. choose properties
c. select the Settings tab
d. Click on the advanced… button
e. Select the Troubleshooting tab
f. move the Hardware Acceleration slider to None
Don’t forget to re-enable the hardware acceleration afterwards, because this has a strong effect on the system’s graphical performance.

4.2.33. Exporting to interlinear text

This function (File > Export as > Interlinearized Text...) is very similar to ELAN’s printing system. Therefore more information can be found in Section 4.2.14. The main difference is that the width of the exported text depends in this case on the number of characters that fits on one line.

Figure 4.48. Set Layout options
After selecting an appropriate layout click on Save as and choose a location and file name. These files can afterwards easily be edited with any text editor (preferably using a fixed-with font). Optionally tick the Insert tabs between annotations box if you prefer to have the whitespace between annotations to be filled with tabs instead of spaces (especially useful when importing a text file into Word).

### 4.2.34. Exporting to HTML

Similarly to the export to interlinear text (see Section 4.2.33) you can also export annotations to a HTML file, through the File > Export as > HTML... menu.

### 4.2.35. Exporting Multiple Files

ELAN offers the possibility to export multiple annotation files as one file. To do so click on File > Export Multiple Files As... and one of the three following options:

- Tab-delimited Text...
- List of Annotations...
- List of Words...

In the dialog window that now opens do the following:

1. Click on the Look in pull down box and browse to the directory that contains the annotation files.
2. Double-click on the annotation file (*.eaf) to select it. It now appears in the rightmost box. Alternatively, you can click on the annotation file name and click afterwards on the >> button.

Repeat this for every annotation file you want to include.

It is also possible to select a complete directory. All .eaf files in a selected directory will be included.

3. Click OK to continue the exporting process; otherwise click Cancel to exit the dialog window without exporting.

The next step depends on which of the three menu options you have chosen:

- **Tab-delimited Text**: Select tiers and options as you would do when exporting a single Tab-delimited Text file (see Section 4.2.22). A column containing the filenames is added to the export file.

  **Note**

  The following options cannot be checked:

  - Restrict to selected time interval: the selected time interval does not necessarily correspond to an interval in the files selected for export.
  
  - Add master media time offset to annotation times: the master media (time offset) of the file currently opened in ELAN does not necessarily correspond to the media (time offset) of the files selected for export.
  
  - Separate column for each tier: in the situation of exporting one file this option would put annotations with the same start and end time on the same row. When exporting more than one file, this would be impossible because of the addition of a column containing the filenames of the source files.

- **List of Annotations**: Select tiers from which the annotations are to be exported. Note that the annotations are not separated into words.

- **List of Words**: Select tiers from which the annotations are to be exported and specify the token delimiters.

After clicking OK you are asked to enter a filename for the new file. Clicking Save will export the file.

**4.2.36. Opening a wave file in Praat**

ELAN offers the possibility to open wave files (or a part of them) in Praat. To achieve this, follow the steps below:

1. If desired, make a selection first (See Section 5.6)

2. Right click in the waveform viewer

3. Choose Open file in Praat or Open selection in Praat

4. If you haven’t specified the location of the praat and sendpraat program yet, you will have to locate them now in the file dialog

5. The praat program containing the wavefile appears

---

5See [http://www.fon.hum.uva.nl/praat/](http://www.fon.hum.uva.nl/praat/)
Figure 4.50. Opening a wave pattern in Praat

Note

Make sure you are using a recent version of Praat (higher than 4.0.5), otherwise this feature will not work.

Note for advanced users: compiling SendPraat on linux

- Make sure a C compiler (like gcc) is installed.
- You will also need the X11 or Xorg development packages (they can be found in a package called xorg-x11-devel or something likewise)
- Replace if0 with if1 in sendpraat.c, as described on http://www.fon.hum.uva.nl/praat/sendpraat.html
- Link the executable with the X11 libraries when you compile sendpraat:

  cc -o sendpraat sendpraat.c -L /usr/X11R6/lib -lX11

4.2.37. Exporting a selection to a wave file with Praat

Similarly to opening a selection with praat you can also carve out a a selection and save it as a separate wave file. Make a selection (see Section 5.6) and right-click in the waveform viewer. Choose Clip Selection With Praat. The selected part will now be stored in the same folder as the original WAV file, with a suffix like _23718_25110.wav, the numbers represent the begin and end, expressed in milliseconds. The selection will also be opened in a new praat screen.

4.2.38. Closing a file

To close a file that is being viewed/edited without exiting ELAN use the File > Close menu option. Alternatively you can also close it by clicking on the arrow in the right upper corner or by pressing CTRL+W.

4.2.39. Exiting ELAN

To quit ELAN wand to close all opened windows, press CTRL+Q or do the following:

1. Click on File menu.
2. Click on Exit.
If you exit ELAN without having saved the changes (see Section 4.2.4), the Saving transcription dialog window appears, e.g.:

**Figure 4.51. Save on exit**

![Save on exit dialog](image)

Checkmark the files for which you want the changes to be saved. Click **OK** to save the changes or click **Cancel** to return to ELAN.

This behaviour differs from earlier ELAN versions. Therefore you will be warned when exiting. If you don't want this warning again the next time, check **Don't show this message again** and click on **OK**.

**Figure 4.52. Exit behavior**

![Exit behavior dialog](image)

### 4.3. Screen display and navigation through a document

Whenever you open, create or import a document, the ELAN window appears. This section introduces you to the setup of the ELAN window (Section 4.3.1), and explains the navigation through it (Section 4.4 and Section 4.5).

#### 4.3.1. Basic Information: The ELAN window

The ELAN window displays the Menu bar, the Media Player options, and up to six Viewers, e.g.:
All Viewers are synchronized and thus display the same point(s) in time. I.e., whenever you access a point in time in one of the Viewers, all the other Viewers will immediately jump to the corresponding point in time.

In all Viewers, color coding is used to facilitate the orientation in the document.

This section introduces the setup of the Viewers, the Menu bar, the Media Player options and the color coding. Detailed information about how to navigate through the ELAN window follows in the subsequent sections.

4.3.2. The Video Viewer

The Video Viewer displays up to four video images (of the *.mpg/*.mov files). However it is possible to link more than four video files. To make videos (in)visible click View > Media Player > in the Elan menu and (un)check a video file name. A video file will not be unlinked when it is made invisible in this way.
Figure 4.54. The video viewer

Note that you can right click on the video viewer to *detach* it, i.e. create a separate window for the video. To re-attach the video window, right click on it and select *attach*.

To change the size of the video viewer you don’t need to detach the video viewer. Instead, you can drag the vertical divider on the right side of the window up and down to make the video viewer respectively smaller and bigger (see also Figure 4.54).

**Note**

In the very unlikely case that you encounter problems while playing video files, uncheck Options > Use native media platform in ELAN’s initial screen.

Right clicking\(^7\) in the video window and selecting Player Info... will display a dialog with information about the video file, e.g.:

Figure 4.55. Video information dialog window

A static picture containing the currently displayed frame can be stored using the context menu of the video window (right click > Save Current Frame as Image...)

\(^7\)For users of a one button mouse on Apple computers: hold the *CTRL* button and click
Clicking on a video copies the coordinates of the mouse cursor relative to the upper left corner of the video to the clipboard. The coordinates can have different formats depending on the modifier key used:

- no modifier key: \(x, y \text{ [original width, original height]}\), where \(x\) and \(y\) are coordinates in the original coordinate system.
- with \texttt{ALT} key: \(x, y\) where \(x\) and \(y\) are between 0 and 1 (0.000, 1.000) identifying a relative position in the (0,0,width,height) image space.
- with \texttt{SHIFT} key: \(x, y\) where \(x\) and \(y\) are coordinates in the original coordinate system (not bothering about original dimension or aspect ratio)

### 4.3.3. The Annotation Density Viewer

The Annotation Density Viewer is a kind of a timeline which allows you to:

- Navigate through the whole media file. The length of this viewer always corresponds to the whole media file, so e.g. by clicking in the middle you will always go to the middle of the media file. The selection is represented as a small grey bar.
- See how many annotations are concentrated at a particular moment of the time (the Annotation Density). The more annotations available for a particular moment, the more the Annotation Density bar is filled. This can be useful to track places in the media file that still have to be annotated.

By default the Annotation Density Viewer shows the annotation density of all tiers. Right clicking the Annotation Density Viewer and selecting a specific tier allows you to view the annotation density of a single tier.

**Figure 4.56. Annotation density viewer**
4.3.4. The Waveform Viewer

The Waveform Viewer displays the waveform of the audio file\(^8\) (**.wav**). Above the waveform, timecode information is displayed. While listening to the sound, a red vertical bar, the crosshair, moves through the waveform and indicates which part of the waveform corresponds to the current point in time. Furthermore, whenever you have selected a time interval, the corresponding part of the waveform will be highlighted in light blue color.

At any time, you can press **ALT** and drag the time axis for a panning effect (i.e. go to the left to go back in the time or to the right to go further). In the case of video files, the waveform is only displayed if there exists an additional **.wav** file (see Section 4.1). If this is not the case, the Waveform Viewer will not be available.

**Note**

On slower machines, the Waveform Viewer may not always update properly when moving to the next page.

Figure 4.57. The waveform viewer

The Waveform Viewer supports 3 modes. You can select the active mode by a right click on the Waveform Viewer. In the menu **Stereo Channels**, the following options are available:

1. Separate. 2 Waveforms are showed, one for each channel.
2. Merged. The 2 channels are merged and the result, one waveform is displayed.
3. Blended. Both channels are displayed on 1 waveform, differences are designated with colors.

Another option in the context-menu (right click) of the Waveform Viewer is **connected**. If this option is checked, the timescale of the Waveform Viewer and the Timeline Viewer are connected:

\(^8\)Different resolutions are supported: 8 bits (mono and stereo), 16 bits (mono and stereo) and 24 bits (stereo). Both PCM and A-law encoded wave files can be loaded.
4.3.5. The Subtitle Viewer

You can turn on the subtitle viewer for a tier by selecting that tier from the pulldown menu in the tab **Subtitle Viewer**. During playback, the Subtitle Viewer displays the annotations of the selected tiers at the current media time, both during playback and in static situations.

It is possible to display up to four of the tiers as a subtitle in the Subtitle Viewer:

1. Select the **Subtitle Viewer** tab in the right upper corner of the ELAN window
2. In the pull-down menu, click on the tier you want to be displayed.
4.3.6. The Grid Viewer

The Grid Viewer displays the content as well as the begin and end time of all annotations from a single tier. You have to activate this Viewer through selecting the Grid tab next to the video window.
It is possible to select annotations within the Grid Viewer (by clicking on them), or to edit them (by double-clicking on them).

By default the Grid Viewer works in single tier mode. If you check the checkbox on the left of the tiers dropdown menu you can switch to multi tier mode. In that case all the annotations of the selected tier will be shown in the grid, together with all symbolic associated tiers (see Section 5.1). Empty cells of symbolic associated tiers can also be filled in this way.

**Figure 4.62. Multiple tiers in the grid viewer**

![Multiple tiers in the grid viewer](image)

**Exporting from the Grid Viewer**

The results as shown in the Grid Viewer can be exported to a (tab-separated) text file, for later manipulation with e.g. a spreadsheet. Follow these steps:

1. First make a selection of the tiers you want to be displayed (and thus exported)
2. Right click on the Grid Viewer and select Export Table as tab-delimited text…
3. Enter the name of the file to be created and choose Save

**Figure 4.63. Export from the grid viewer**

![Export from the grid viewer](image)

**4.3.7. The Text Viewer**

The text viewer shows all values of all annotations on a selected tier as ongoing text. Within this viewer, there are 3 kinds of highlighting shown:
• Text inside a red box: the value of the annotation on the selected annotation tier that matches the current point of time.

• Text inside a dark blue box: the active annotation (see also Section 4.3.8)

• Text with a light blue background: the selected time interval.

Optionally, you can make the annotation boundaries visible in the text viewer. Right click in the text viewer and select Toggle visualization to enable this. The boundaries are marked by a dot.

Figure 4.64. The text viewer

4.3.8. The Timeline Viewer and the Interlinear Viewer

All annotations can be displayed in the Timeline Viewer or the Interlinear Viewer. Only one of the two Viewers can be switched on at a time.

The Timeline Viewer is always shown when a document is opened in ELAN. It displays the tiers and their annotations, whereby each annotation corresponds to a specific time interval. Above the tiers, a timescale is displayed. During playback, a red vertical bar, the crosshair, moves through the annotations and indicates the current point in time. Furthermore, whenever you have selected a time interval, it will be highlighted in light blue color; and whenever you have selected an annotation, this becomes the active annotation and will be highlighted in a dark blue frame.

If desired the latter can also be indicated with a bold line. To activate this, right click on an annotation somewhere in the timeline viewer and check the Active Annotation Bold box in the context menu.
Figure 4.65. The timeline viewer

In the Timeline Viewer you can (a) select and modify time intervals (see Section 5.6) and (b) enter annotations (see Section 5.7).

The Interlinear Viewer offers an alternative perspective on the tiers and their annotations. It shows parent-child relations between annotations using vertical text alignment (interlinearization). You can enable it by selecting the Show Interlinear Viewer radio button when you right-click on the tier name’s panel and select Viewer. Switching it on, will automatically switch off the Timeline Viewer.

The following screenshots compare how information is displayed in the two Viewers.
Whenever the Interlinear Viewer is switched on, it displays an annotation block (i.e., an independent, time-alignable parent annotation together with its referring annotations, see Section 5.1). To move forward/backward to the next block, click on the arrow icons at the top of the Viewer. During playback, the Viewer automatically moves forward to the next annotation block.

The Interlinear Viewer differs from the Timeline Viewer in that it does not allow to modify the time interval or to enter new annotations. It is similar to the Timeline Viewer in that it allows to edit existing annotations.
The Tier Name Panel

The Tier Name Panel gives an overview of the different existent tiers. Both tier names (see also Section 5.1 and Section 5.4) and tier types are defined by the user (see also Section 5.3). One of the tiers in the Tier Name Panel is the active tier (indicated by its underlining and red color), which means that new annotations will be added to this tier (when pressing ALT+N).

Figure 4.67. The tier name panel

To make a tier the active tier, choose one of the following actions:

- Double click on a tier label.
- Right click in the Timeline or Interlinear Viewer and choose Active Tier.
- Select the active tier with the keyboard shortcut CTRL + ARROW UP/DOWN

To select the tiers to display (and their order) see Section 4.3.16 and Section 4.3.18.

It is possible for ELAN to show the number of annotations per tier. Right click on the Tier Name Panel and select Show Number of Annotations.

4.3.9. The Timeseries Viewer

The Timeseries Viewer can display time series data as line graphs. Like the Timeline and Waveform viewer, it has a horizontal timescale bar, a red vertical crosshair indicating the media time and a light blue rectangle to highlight the selected time interval. It has also the same zoom and pan options.

It can display multiple “trackpanels” and each trackpanel can display multiple “tracks”. Trackpanels and tracks can be added and removed via a popup menu. Each trackpanel derives its value range (vertical axis) from one of the tracks. The viewer has a facility to transfer data from a track to annotation values. Based on
the time intervals of the annotations on a chosen (time-alignable) tier, the minimum, maximum or average of
the data within these intervals of the selected track will be copied to annotations on a dependent, symbolically
associated tier.

The Timeseries Viewer will be created after at least one supported timeseries data file\(^9\) has been associated
to the transcription via menu Edit > Linked Files and then the tab “Linked Secondary Files”. These data
files can be synchronized to the media files in the “Media Synchronization Mode”.

**Figure 4.68. The timeseries viewer**

![Timeseries Viewer](image)

Displaying data from an already linked CSV/Tab delimited text file in the Timeseries Viewer is done as
follows:

1. Right click in the Timeseries Viewer and select Configure Tracks....

**Figure 4.69. Timeseries Viewer popup menu**

![Timeseries Viewer popup menu](image)

\(^9\)Currently supported file formats are a proprietary .log file produced by MPI CyberGlove software, a special kind of plain text (.txt) file,
containing a time-value pair on each line, and CSV/Tab delimited text files. Software developers can add support for other formats by
implementing a Service Provider Interface (more information can be found in the source code release notes).
2. If you have more than one file linked as secondary file, choose the file you wish to use from the pull down menu that is now displayed and click OK.

3. In the next window you see a sample table with several lines and columns of the chosen file. At least one of the columns must contain time data. Select that column by selecting the appropriate column number at Time Column Index. If the time codes have a fixed interval, you can check the option Continuous Rate. Its underlying purpose is to speed up the calculations for displaying a data track.
4. After you have selected a column as the time column, you can begin creating tracks. On the Add tab, enter a Track Name and optionally a Track Description. Select the number of the column.
in the data that you want to use for this track and specify the range for the vertical axis. This can be automatically calculated by selecting Calculate Range From Data or it can be set manually by selecting Manual Setting and entering the Minimum Value and Maximum Value.

The Derivative option allows you to display the first, second or third derivative of your data. Derivatives are useful if we are, for example, dealing with data that represent the position of an object, but we wish to see the velocity of that object. Because velocity is the first derivative of position, we would select 1. In this example, 2 would represent the acceleration and 3 the rate of change of acceleration, also called jerk or jolt.

Enter the units of your data, for instance meters for position or Pascal (Pa) for pressure at the Units (String) option. Select a color by clicking the colored box at Track Color.

Finally click the Add button. The track is now added to the list of Current Tracks which is above the Add tab. Continue adding tracks for each column of data you wish to display. After adding tracks, click on the Close button.

5. To display the track right click on the Timeseries Viewer again. Select Add TrackPanel to add a new trackpanel. Right click the new trackpanel and select TrackPanel > Add Track. A list of not yet displayed tracks is displayed. Click one to add it to the trackpanel.

The other option from the popup menu are:

• Zoom: zoom in and out horizontally.
• Fit Vertically: fit the trackpanel(s) vertically to the Timeseries Viewer window.
• Remove TrackPanel: remove current trackpanel.
• Add TrackPanel For Each Track: create a trackpanel for each of the existing tracks.
• Remove All TrackPanels: remove all trackpanels form the Timeseries Viewer window.
• TrackPanel > Set Range For Panel: set the vertical range to the range specified for a track.
• TrackPanel > Remove Track: remove a track from the current trackpanel.
• TrackPanel > Add All Tracks: add all tracks to the current trackpanel.
• TrackPanel > Remove All Tracks: remove all tracks from the current trackpanel.
• Extract Track Data: Extract data from a track and add it to a tier.

4.3.10. The Menu options

The following Menu options are available at the top of the ELAN window:

• File: use this menu to open, create, save, im-/export or exit a document (see Section 4.3) and to configure automatic backups.
• Edit: use this menu to define, modify and delete annotations, tiers and linguistic types (see Chapter 5).
• Search: use this menu to search for text (see Section 5.8).
• View: use this menu to get an overview of the tier dependencies (see Section 5.1) and the shortcut keys.
• Options: use this menu to (de)activate the Bulldozer mode (see Section 5.6.7), to choose between annotation mode and synchronization mode and to select a language and video standard.
### 4.3.11. The Media Player options

With the Media Player options, you can control the playback of the file. The following options are available at the bottom and at the left side of the ELAN window:

**Figure 4.71. The media player options**

![Image of the media player options]

**Table 4.1. Media Controls**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Play]</td>
<td>Go to the beginning of the video/audio fragment</td>
<td>CTRL+B</td>
</tr>
<tr>
<td>![Play]</td>
<td>Go to the previous scroll view (make the beginning point of the current timeline view the end point)</td>
<td>CTRL+PAGE UP</td>
</tr>
<tr>
<td>![Play]</td>
<td>Go back one second</td>
<td>SHIFT+LEFT</td>
</tr>
<tr>
<td>![Play]</td>
<td>Go back one frame (≈ 40 ms for PAL, 33.4 ms for NTSC)</td>
<td>CTRL+LEFT</td>
</tr>
<tr>
<td>![Play]</td>
<td>Go back one “pixel” on the timeline viewer (smallest unit, depends on the zoom factor of the timeline viewer, default value 10 ms)</td>
<td>CTRL+SHIFT+LEFT</td>
</tr>
<tr>
<td>![Play]</td>
<td>Start/Pause the playback</td>
<td>CTRL+SPACE</td>
</tr>
<tr>
<td>![Play]</td>
<td>Go to the next “pixel” on the timeline viewer (smallest unit)</td>
<td>CTRL+SHIFT+RIGHT</td>
</tr>
<tr>
<td>![Play]</td>
<td>Go to the next frame</td>
<td>CTRL+RIGHT</td>
</tr>
</tbody>
</table>
Table 4.2. Selection Controls

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Icon" /></td>
<td>Go to the next second</td>
<td>SHIFT+RIGHT</td>
</tr>
<tr>
<td><img src="image2" alt="Icon" /></td>
<td>Go to the next scroll view</td>
<td>CTRL+PAGE DOWN</td>
</tr>
<tr>
<td><img src="image3" alt="Icon" /></td>
<td>Go to the end of the media fragment</td>
<td>CTRL+B</td>
</tr>
</tbody>
</table>

Table 4.3. Annotation Controls

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image4" alt="Icon" /></td>
<td>Play the selected interval</td>
<td>SHIFT+SPACE</td>
</tr>
<tr>
<td><img src="image5" alt="Icon" /></td>
<td>Clear the selection</td>
<td>CTRL+C</td>
</tr>
<tr>
<td><img src="image6" alt="Icon" /></td>
<td>Move the crosshair to the begin / end of selection</td>
<td>CTRL+- or CTRL+SHIFT+K</td>
</tr>
</tbody>
</table>

Table 4.4. Selection Mode

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image7" alt="Icon" /></td>
<td>While playing, select an interval automatically</td>
<td>CTRL+K</td>
</tr>
<tr>
<td><img src="image8" alt="Icon" /></td>
<td>Keep playing the selected interval (if used together with play selection)</td>
<td>CTRL+L</td>
</tr>
</tbody>
</table>

- The timecode can be displayed in the following formats: "hours:minutes:seconds.milliseconds" and ""hours:minutes:seconds.frames"". It can be used to access points in time (by clicking on it and entering a value in "hh:mm:ss:ms" format). To change the display format, right click on it and select a format from the menu. The SMPTE timecode formats PAL and NTSC only indicate the way time values are converted to frame numbers; this is independent of the actual video standard of the associated video(s).
4.3.12. The color coding

In all its displays, ELAN makes use of recurring colors in order to facilitate the orientation in the document. The following colors are used:

- Red: Position of the crosshair (i.e., current point in time);
- Light Blue: Selected time interval;
- Dark Blue: Active annotation.
- Black with long segment boundaries: Annotations that can be aligned to the time axis.
- Yellow with short segment boundaries: Annotations that cannot be aligned to the time axis.

For example:

How to change the display of the ELAN window

The ELAN window setup as described and illustrated in Section 4.3.1 above is the default display. But you can easily change the display according to your needs. The following options are available:

- increasing/decreasing the size of the ELAN window (Section 4.3.13);
- switching Viewers on/off (Section 4.3.14);
• increasing/decreasing the size of Viewers (Section 4.3.15);
• switching tiers on/off (Section 4.3.16);
• rearranging the order of tiers (Section 4.3.17 and Section 4.3.18);
• displaying a tier in the any of the tab pane’s viewers (Section 4.3.5 and further);
• changing the time resolution (Section 4.3.19);
• changing the font size (Section 4.3.20);
• de-attach/re-attach the video window (Section 4.3.2).

4.3.13. Increasing/decreasing the size of the ELAN window

The size of the ELAN window can be increased or decreased. Do one of the following:

1. Go with the mouse to the borders of the ELAN window. The mouse will turn into a double-headed arrow. Click and move it to increase/decrease the size of the window.
2. In the top right corner of the ELAN window, click on the Maximize icon to activate the full-screen modus; click on the Restore Down icon to return to the previous size.

4.3.14. Switching Viewers on/off

Depending on the type of media file, ELAN automatically displays three Viewers (Video, Waveform and Timeline Viewer). Furthermore one can choose an additional viewer in the tabs on the right of the video Viewer: a text viewer, a grid viewer or subtitle viewer. Note that it is not possible to activate both the Timeline and the Interlinear Viewer at the same time.

Note

If a media file is not available (e.g., the *.mpg/* .mov file in case of audio data, or the *.wav file in case of some video data), the corresponding Viewer is not available either.

4.3.15. Increasing/decreasing the size of Viewers

The size of all Viewers (except for the Video Viewer) can be increased and decreased relative to the size of other Viewers. Do one of the following:

1. Use the up/down-arrows of the split-pane.

   Click on the up/down-arrow to increase/decrease the size of the corresponding Viewer.

2. Use the mouse.

   Go with the mouse to the split-pane. The mouse will turn into a double-headed arrow. Click and move it up/down to increase/decrease the size of the corresponding Viewer.
4.3.16. Switching tiers on/off

By default, ELAN automatically displays all available tiers, but each tier can be switched on or off manually, allowing you to focus only on the tiers of interest for the task at hand.

To switch tiers on/off, do the following:

1. In the Timeline Viewer, right-click in the tier name panel.

2. In the pull-down menu select the submenu Visible Tiers and (un)check the tiername

Switching off a tier can be done directly by right clicking on its name and selecting hide <tiernane> from the pull down menu. Alternatively you can open a window containing all tier names by selecting Show/Hide More… in the popup menu.
Figure 4.75. Switching tiers on/off

If you switch a tier on, it will be put on the place where you clicked.

4.3.17. Rearranging the order of tiers

Within the Timeline or Interlinear Viewer, you can rearrange the order in which the tiers are displayed. Just drag the tier label to its new location. The tiers will be displayed in the new order.

Figure 4.76. Rearranging the order of tiers

If you exit the document, ELAN will save the order of tiers in the following way: first, all activated tiers (in the order as they appear in the Timeline or Interlinear Viewer), followed by all non-activated tiers in alphabetical order.
4.3.18. Sorting tiers

The order of the visible tiers in the timeline and interlinear viewer can be altered. To achieve this, right click in the tier name panel and select the submenu Sort Tiers. Then choose one of the following options:

Table 4.5. Sort tier options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unsorted: no specific order.</td>
<td></td>
</tr>
<tr>
<td>Sort by Hierarchy: display a tree with the hierarchical structure of the tiers</td>
<td></td>
</tr>
<tr>
<td>Sort by Linguistic Type: group tiers by their linguistic type</td>
<td></td>
</tr>
<tr>
<td>Sort by Participant: group tiers with annotations of a single participant</td>
<td></td>
</tr>
</tbody>
</table>

4.3.19. Changing the time zoom

The default zoom for the Waveform and the Timeline Viewer is 100%, corresponding to 10 milliseconds per pixel. The zoom can be changed simultaneously for both Viewers. Do the following:

1. Click with the right mouse button on either the Waveform Viewer or the Timeline Viewer.
2. Go to Zoom. The following menu appears:
3. Click on a zoom rate to select it. A checkmark appears next to the selected zoom rate.
   
   • Click on a lower percentage to get a finer zoom.
   
   • Click on a higher percentage to get a wider zoom.

4.3.20. Changing the vertical (intensity) zoom

Sometimes it can be handy to zoom in on the intensity of the signal displayed in the waveform viewer. This way you can more easily make the distinction between parts where someone is speaking and those where there is a silence. Such a visual amplification is available through the right-click context menu in the waveform viewer:
Please note that this vertical zoom does not change the audio characteristics in any way.

4.3.21. Changing the font size

The default font size is 12 pt., but it can be changed separately for the different annotation viewers in ELAN. Do the following:

1. Right click on one of the viewers (Grid, Subtitle, Text, Timeline, Interlinear Viewer).

2. Go to Font size. The following menu appears:
3. Click on a font size to select it. A checkmark appears next to the selected font size.

### 4.3.22. Font Browser

If you are not sure that the font you want to use can display all the (special) characters of an annotation (for instance IPA characters), you can check this by using the Font Browser utility ELAN offers. Click on View > Font Browser... to open the Unicode Font Finder-Explorer (see Figure 4.80). In the first list of the explorer you can select a system font for which you want to know what Unicode subsets it can display. These subsets are displayed in the list below the list of system fonts. If you click on a Unicode subset, this subset is displayed in a new window (Font Browser for Codepage).

Another way of checking whether your special characters can be displayed in the desired font, is to enter text in the bottom textbox of the Font Finder-Explorer and click on Check. Now the lists on the right of the Font Finder-Explorer will display the fonts and Unicode subsets that can display the text in the textbox. Clicking on a Unicode subset will display that subset in the Font Browser for Codepage-window.

Clicking the Clear button will clear the lists, except for the list of system fonts.
Figure 4.80. Font Finder-Explorer

4.3.23. Editing preferences

Some preferences can be changed in a dedicated dialog window. Click Edit > Preferences > Edit Preferences. Select a category in the list to the left of the dialog window. The categories and their preferences are:
Figure 4.81. Edit preferences

• Editing

- Deselecting the inline text edit box commits changes:

  If this option is not checked (default) changes made to an inline edit box are discarded if you leave the edit box without explicitly committing the changes. This happens for instance if you click outside the current edit box.

  If this option is checked changes are committed if you leave the current inline edit box.

- Enter key commits changes in the inline edit box:

  If this option is not checked (default) pressing ENTER will insert a line break (a.k.a. newline) in an inline edit box. To commit the changes you should hit CTRL+ENTER.

  If this option is checked ENTER will not insert a line break. It commits the changes as if you pressed CTRL+ENTER.

• Media navigation

- Frame forward and frame backward jump to begin of next or previous frame:

  If this option is not checked (default) clicking the frame forward button (see Section 4.3.11) will put the crosshair forward by the amount of ms in one frame. So if the crosshair is in the middle of a frame, clicking frame forward will put the crosshair in the middle of the next frame. The same goes for frame backward.
If this option is checked the crosshair is put at the beginning of the next (or previous) frame no matter where it is in the current frame.

4.3.24. Importing and exporting preferences

The following display preferences can be imported and exported:

- Font
- Fontsize
- Tier name color
- Selected tier per viewer
- Visible/hidden tiers

Importing and exporting these preferences make it possible to apply preferences to another document. To export preferences click Edit > Export Preferences..., select a destination folder, enter a filename and click on Save. To import preferences click Edit > Import Preferences..., look up the preference file and click on Select.

4.4. How to navigate through a document

ELAN supports the following options for navigating through a document:

- accessing points in time (Section 4.4.1);
- going to a selection (Section 4.4.2);
- jumping step by step through a document (Section 4.4.3);
- navigating using the Timeline Viewer (Section 4.3.11)
- navigating using the Grid Viewer (Section 4.4.4);
- navigating using the Interlinear Viewer (Section 4.4.5).

All Viewers are synchronized in time, i.e., when you navigate to a specific point or selection in one Viewer, all other Viewers will immediately jump to the corresponding point or selection:

- The Video Viewer will display the corresponding video frame
- The Waveform Viewer will display a crosshair at the corresponding location in the waveform.
- The Subtitle, Timeline and Interlinear Viewers will display the corresponding annotation(s).

4.4.1. Accessing points in time

To access a point in time, do one of the following:

1. Use the timecode box.

   a. Click on the timecode above the media playback controls (left side of the ELAN window). The Goto dialog window appears.
b. Enter the timecode in the following format: “hh:mm:ss.sss” (hours:minutes:seconds.milliseconds). The crosshair jumps immediately to the selected timecode.

You can omit part of the timecode information:

- If the digits are “00”, you can omit “hours:”, “hours:minutes:”, or “hours:minutes:seconds:”.
- It is optional to specify “.milliseconds”.

**Note**

The character preceding the milliseconds is a dot, not a colon.

2. Use the crosshair
Figure 4.83. Use the crosshair

Click somewhere in the Text, Subtitle, Timeline, Waveform or Grid Viewer. The crosshair will jump to that point. By holding the ALT button and dragging the time axis to the left or to the right you can scroll through the annotations.

3. Use the media control buttons

See Section 4.3.11

4.4.2. Going to the borders of a selection

If you have made a selection (see Section 5.6), you can move the crosshair to the begin or end of that selection from anywhere within the file.

To jump to the begin, click on the button, which is part of the Selection Controls. Then the button will show an arrow in the other direction, which brings the crosshair to the end of the selection.

4.4.3. Jumping step by step through a document

It is possible to move the crosshair back and forth step by step. To achieve this, use one of the media controls as described in Section 4.3.11.

If the media framework Elan is using cannot determine the video format, you can alter the step size when using the next/previous frame control. This is useful in order to work with a “natural” frame duration, depending on the video format that is used (i.e. 25 frames/second for PAL or +/- 30 frames/second for NTSC).

Do the following:
1. Click on Options menu.

2. Go to Set Frame Length. The following menu appears:

   **Figure 4.84. Set Frame Length menu**

   ![Set Frame Length Menu]

   Select an option from the menu:

   - **PAL**: The 1 frame stepsize for video data corresponds to one PAL frame (40 ms)
   - **NTSC**: The 1 frame stepsize for video data corresponds to one NTSC frame (33 ms)

3. Click on a Frame Length mode to select it. A radio bullet appears next to the selected step mode.

### 4.4.4. Viewing a list of annotations within one tier (Grid Viewer)

ELAN allows you to list all annotations from a single tier, and then select one annotation and jump to it.

To activate the Grid Viewer, click on the **Grid** tab:
Figure 4.85. The grid viewer

The structure of the Grid View window is as follows:

Figure 4.86. Structure of the grid viewer
You can change the Grid Viewer’s interface at any moment by right clicking in the Grid Viewer. A context menu will appear:

**Figure 4.87. Grid viewer with context menu**

In this context menu, you can choose between the following options:

- choose the columns displayed in the Grid Viewer
- changing the Grid Viewer’s font size
- toggle between the time code format (hh:mm:ss.mmm) and milliseconds

You can use the Grid Viewer window to navigate to an annotation in the ELAN window. You have the following two options:

1. Move the crosshair to the begin of an annotation.
   
   Do the following:
   
   a. In the Grid Viewer window, click with the mouse button on an annotation.

   A red triangle appears next to the annotation in the Grid Viewer window, and the crosshair moves to the beginning of that annotation in the ELAN window.

2. Select a time interval.
   
   Do the following:
   
   a. In the Grid Viewer window, click with the mouse button on the first annotation that you want to select.

   b. Keep the mouse button down and drag the mouse to another annotation.

   In the Grid Viewer window, all selected annotations are highlighted in light blue color. In all other windows, the corresponding time interval is selected and highlighted in light blue color (starting with the beginning of the first annotation and ending with the endpoint of the last).

   **Note**

   Selecting a time interval also changes the current time. This happens implicitly by moving the crosshair to the begin of the annotation.
4.4.5. Jumping from annotation to annotation (Interlinear Viewer)

In the Interlinear Viewer, you can jump from one annotation block forward/backward to the next block. Do one of the following:

1. Click on the left arrow button at the top of the Interlinear Viewer to move to the previous annotation block.
2. Click on the right arrow button at the top of the Interlinear Viewer to move to the next annotation block.

4.5. How to play a document

ELAN supports the following options for playing a document:

- playing a document (Section 4.5.1);
- playing a selection (Section 4.5.2);
- playing around the crosshair/selection (Section 4.5.3);
• playing in slow motion (Section 4.5.4).

4.5.1. Playing a document

During playback, the red crosshair moves through the Waveform, Timeline, Interlinear, Annotation Density, Text and Grid Viewers, indicating the point in time that is being replayed. If you stop the playback, the crosshair will stop at this point in time. The playback will resume from this point and will continue until the end of the document, or until the playback is paused again.

Make use of either one of the following three options to start/pause the playback:

1. Use the Play/Pause button located under the Video window:
   a. Click on the Play icon to start playback. After the playback starts, the Play icon turns into a Pause icon.
   
   Figure 4.90. Play/pause button

   ![Play/pause button]

   b. Click the Pause icon to pause the playback again.

2. Use the Shortcut key CTRL+SPACE to start the playback. Use it again to pause the playback.

   Note

   If two or more ELAN documents are open at the same time, the sound may not work properly. Should this happen, close all documents except for one.

4.5.2. Playing a selection

It is possible to play only a selected part of the document. Do the following:

1. Make a selection (see Section 5.6), or click on an annotation.

2. To play the selection, do one of the following:
   a. Click on the Play Selection icon.
   
   b. Or use the shortcut key SHIFT + SPACE.
   The selected part is played immediately. To listen to the selection again, repeat step 2.
Note

If the crosshair is positioned somewhere within the selection (i.e., if it had been manually moved forward or backward, see Section 4.4.3), playback will start from that position and stop at the end of the selection. Otherwise, the whole selection will be played.

If you want to loop over the selection, be sure to check the Loop Mode box (next to the Selection Mode checkbox).

4.5.3. Playing around a selection

When playing a selection it is possible to extend the playback interval with a context up to a few seconds before and after the selection. This can e.g. be useful to get an idea about the preparation and the finishing of a gesture.

1. Click on Options menu.
2. Go to Play around selection. The following dialog appears:

**Figure 4.91. Play around selection**

3. Choose how many (milli)seconds or frames there should be played before and after the selection. Click on the OK button.
4. Now make a selection and press CTRL-SHIFT-SPACE. This keyboard shortcut is the only way to play around a selection.

4.5.4. Playing in slow motion

To change the playback rate, use the Rate slider to the right of the video window. The following options are available:

- Click somewhere above or below the slider to increase or decrease the playback rate by 1%.
- Move the slider up or down to increase or decrease the playback rate.
- Enter the desired playback rate in the box at the left of the slider and press the key ENTER. ELAN accepts rates between 1% and 200%.
Figure 4.92. Playback rate

Once you have selected a playback rate, the document will be played at the selected rate. If you want it to be played at a different rate, you have to manually change the playback rate, repeating the steps above.

Note

On slower machines, the slow motion playback may not work properly.

4.5.5. Changing playback rate and volume via the keyboard

In the Options > Rate and volume toggle… menu, a preset value can be specified for the playback rate and volume which can be activated through a keyboard shortcut:

- **CTRL+SHIFT+R**: alternate the current volume with the preset value
- **CTRL+ALT+R**: alternate the current playback rate with the preset value
Chapter 5. Annotations

You can use the ELAN program for annotating your data. This annotation process involves three steps: defining linguistic types and tiers (see Section 5.3.1 and Section 5.4), selecting time intervals (see Section 5.6), and entering annotations (see Section 5.7).

5.1. Basic Information: Annotations, tiers and linguistic types

The following illustration shows an example of an annotation document:

Figure 5.1. Annotation basics

Each annotation is entered on a tier and assigned to a time interval (either directly or to the time interval of another annotation).

All tiers can be displayed simultaneously in the Timeline or Interlinear Viewer (Section 4.3.8), but four of them can be displayed additionally in the Subtitle Viewer. It is useful to select the tier you are currently working on in a Subtitle Viewer because this viewer is bigger and supports line wrapping (which makes it easier to read along during playback).

It is also possible to select one tier as the active tier. This can be done by double clicking on the tier name in the Timeline or Interlinear Viewer. When a tier is active, its name is underlined and displayed in red. Adding a new annotation to a tier by the keyboard shortcut ALT+N is only possible when that tier is active (see Section 5.7).

A tier is a set of annotations that share the same characteristics, e.g., one tier containing the orthographic transcription of the speaker’s utterances, and another tier containing the free translation of these utterances.
The following two types of tiers exist:

- Independent tiers, which contain annotations that are linked directly to a time interval, i.e., they are “time-alignable”.

- Referring tiers, which contain annotations that are linked to annotations on another tier (i.e., to annotations on their so-called “parent tier”). They are usually not linked directly to the time axis. (Some of them may be linked – but only within the time interval determined by their independent parent tier, see below.)

One example: a transcription tier could be independent and time-alignable, as it is linked directly to the time intervals of the speaker’s utterances. A translation tier, by contrast, would be referring and not time-alignable: it refers to the transcription tier – not directly to the time axis. By definition, it inherits its time alignment from the transcription tier, i.e., from its parent tier.

In the Timeline and Interlinear Viewers, the label of a referring tier is assigned the same color as the label of its independent parent tier.

It is possible to build up nested hierarchies, i.e., tier A can be the parent tier of tier B, and tier B can be the parent tier of tier C, etc.

For example:

**Table 5.1. Nested tier dependencies**

<table>
<thead>
<tr>
<th>tier:</th>
<th>type:</th>
<th>hierarchical relation:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ref (referent)</td>
<td>independent</td>
<td>parent of tx and ft</td>
</tr>
<tr>
<td>tx (text)</td>
<td>referring</td>
<td>parent of mb</td>
</tr>
<tr>
<td>mb (morpheme break)</td>
<td>referring</td>
<td>parent of gl and ps</td>
</tr>
<tr>
<td>gl (gloss), ps (part of speech)</td>
<td>referring</td>
<td>-</td>
</tr>
</tbody>
</table>

**Figure 5.2. Tier dependencies**
Figure 5.3. Tier dependencies in the timeline viewer

Note

Parent and child tiers are linked in such a way that some changes made on a parent tier will also affect its child tiers (but not vice versa):

- If you delete a parent tier, all its child tiers are automatically deleted as well. Similarly, when you delete an annotation on a parent tier, all corresponding annotations on its child tiers are deleted as well.

- If you change the time interval of an annotation on a parent tier, the time interval of the corresponding annotation on all its child tiers are changed accordingly. The time interval of a child tier cannot be changed independently.

You can view the existing dependency relations by clicking on View menu, and then on Tier Dependencies.

Each tier is assigned to a linguistic type (see also Section 5.3). A linguistic type denotes the linguistic data that is contained in the referring tier. Examples of names for linguistic types are utterances, words, orthography, phonetic transcription, PoS (part of speech), but any name can be used. Each linguistic type specifies a number of constraints that hold for all tiers assigned to that type. Such constraints are bundled into so-called ‘stereotypes’. The following four stereotypes are currently available:

Table 5.2. Linguistic type stereotypes

<table>
<thead>
<tr>
<th>Stereotype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>The annotation on the tier is linked directly to the time axis, i.e., the annotation is entered on an independent tier. Two annotations cannot overlap.</td>
</tr>
<tr>
<td>Time Subdivision:</td>
<td>The annotation on the parent tier can be sub-divided into smaller units, which, in turn, can be linked to time intervals. Note that there are no time gaps allowed, i.e., the smaller units have to immediately follow each other. E.g., an utterance transcribed on a parent tier can be sub-divided into words – each of which is then linked to its corresponding time interval.</td>
</tr>
</tbody>
</table>
**Annotations**

<table>
<thead>
<tr>
<th><strong>Note</strong></th>
<th>Annotations on such tiers are time-alignable. They differ from annotations on independent tiers in that they are assigned to an interval that is contained within the interval of their parent annotation.</th>
</tr>
</thead>
</table>

- **Symbolic Subdivision:**
  Similar to Time Subdivision, except that the smaller units cannot be linked to a time interval.
  E.g., a word on a parent tier can be sub-divided into individual morphemes (which are not linked to a time interval).

- **Included In:**
  All annotations fall within the borders of the parent tier. However, there can be gaps between the child annotations.
  E.g., a sentence with a silence can be split up into words while the silence corresponds to a gap in the child annotations (i.e. the separate words).

- **Symbolic Association:**
  The annotation on the parent tier cannot be sub-divided further, i.e., there is a one-to-one correspondence between the parent annotation and its referring annotation.
  E.g., one sentence on a parent tier has exactly one free translation. Or one word has exactly one gloss.

*A similar stereotype exists in Media Tagger, so it is especially useful for the import of such files.*

The following example illustrates the four different stereotypes (see also Figure 5.3):

---

107
5.2. Data categories

In ELAN users are free to invent their own tier setup and labeling method. This flexibility is often necessary due to the nature of the data that is to be transcribed. Moreover, people that are involved in the transcription process may not be fluent in English and as a result an international (English) annotation scheme is not applicable. In those cases a controlled vocabulary (see Section 5.5) and templates (see Section 4.2.9) are convenient tools to help annotators.

The downside of all this flexibility is the amount of work involved to make language resources interoperable. When dealing with only a few resources, data can be manageable, but with an increasing number of resources a convenient way to make them interoperable becomes more important. For this purpose the ISO Data Category Registry is developed.

The Data Category Registry (or DCR) is an list of linguistic concepts covering a range of linguistic domains. The concepts in the DCR can be referenced to from all sorts of tools and resources. Therefore, the DCR acts as an intermediate between those tools and resources.

Referencing to a Data Category is implemented in ELAN as follows. Depending on the type of data you are referencing from (linguistic type (Section 5.3.6), controlled vocabulary entry (Section 5.5.2) or annotation (Section 5.7.12)), the following or a similar window is displayed. 

You can define an unlimited number of tiers. It is useful to make decisions about the type of information that you want to enter (and consequently about the type of tiers that you need) at a relatively early stage in the annotation process. However, it is always possible at a later stage to change the parent of a dependent tier (see Section 5.4.5) or to copy a tier (Section 5.9.2) and to alter the copy.
Figure 5.5. Local Data Category Selection

The left panel shows the profiles for which there are data categories in stored on your local system. In Figure 5.5 the only option is All Profiles. Selecting this option will show all data categories of all profile in the left panel. Since there are no profiles in the left panel, the middle panel does not display any data category. To add categories, click on Add Categories. The following window appears:

Figure 5.6. Remote DCR

This window displays the DCR on a remote server. It includes all profiles and the data categories of those profiles. To select one or more data categories for local storage first click a profile in the left panel. All data categories of the selected profile are displayed in the middle panel ordered by alphabet, ID or Broader Concept. If you select a data category, information of the category is displayed in the right panel. For instance, the data category partOfSpeech has Id 1345 as can be seen in Figure 5.6. Holding the CTRL key while clicking multiple lines in the middle panel enables you to select more than one data category. The
same holds for using the *SHIFT* key for selecting a range and using *CTRL+A* for selecting all categories from the list. Click on **Apply** to storing the selected data categories on you local system. Figure 5.7 shows the result on the Local Data Category Selection:

**Figure 5.7. Local Data Category Selection: Result**

In the same way as described above more data categories, also from other profiles, can be selected and stored on your local system.

The original purpose of this system is to associate (parts of) your data to a common labeling system to improve interoperability between resources and tools. To do so, select a data category and click on **Apply**. This will associate the selected data category to an annotation, entry of a controlled vocabulary or linguistic type, depending on the point from which you entered the Local Data Category Selection.

### 5.3. How to define a linguistic type

ELAN supports the following options:

- adding a new linguistic type (Section 5.3.1 and Section 5.3.2);
- changing the attributes of a linguistic type (Section 5.3.3);
- deleting a linguistic type (Section 5.3.4);
- importing a linguistic type (Section 5.3.5).

#### 5.3.1. Adding new linguistic types

Do the following to add a new linguistic type:

1. Click on **Edit** menu.
2. Click on **Add New linguistic type**… The **Add type** dialog window appears.
3. Define the linguistic type (see Section 5.3.2).
4. Click **Add** to save the linguistic type. Otherwise click **Close** to exit the window without saving.
5.3.2. Creating linguistic types

Every tier is assigned to a linguistic type. The linguistic type specifies the stereotypical constraints (and, as a consequence, whether or not the tiers are time-alignable).

Information about the relationship between tiers is given in two different places: for each individual tier it is given in the Add tier dialog window (see Section 5.4.1), and for all tiers belonging to one linguistic type it is given in the Add type window (this section), i.e.:

- Add tier attributes window: specify the parent tier of the individual tier.
- Add type window: specify the stereotypical constraints of tiers belonging to one type.

To create a linguistic type, do the following:

1. Click on the Type menu.
2. Either go to Add New linguistic type…. In the latter case, click on the linguistic type that you want to change when the Add dialog window appears:

**Figure 5.8. Add a linguistic type**

Enter the following information:

1. Go to Type name. Enter/change the name for the type.
2. Go to Stereotype. Select the stereotypical constraint relevant to its tiers (see Section 5.1).
3. Optionally select a controlled vocabulary (see Section 5.5.6).

After you have selected a stereotypical constraint, ELAN automatically enters the correct value next to the box Time-alignable.

Click Add to save the settings; otherwise click Close to exit the window without saving them.
5.3.3. Changing linguistic types

Do the following to change the attributes of an already existing linguistic type:

1. Click on Edit > Change linguistic type… The Change type dialog window appears.
2. The labels of all available linguistic types are displayed in the pull down menu, e.g.:

**Figure 5.9. Change a linguistic type**

3. Click on the linguistic type whose attributes you want to change.
4. Change the settings.
5. Click Change to save the changes. Otherwise click Close to exit the window without saving the changes.

5.3.4. Deleting linguistic types

To delete a linguistic type, do the following:

Click on Edit menu.

1. Go to Delete linguistic type...
2. A dialog window appears. The names of all available linguistic types are displayed in the pull down menu, e.g.: 
Figure 5.10. Delete a linguistic type

3. Click on the type you want to delete.

4. Click Delete to delete the type; otherwise click Close to close the dialog window.

You can only delete a linguistic type if it is not used by any of the tiers. If it is used, the following error message appears:

Figure 5.11. Linguistic type is used

5.3.5. Importing linguistic types

It is possible to import linguistic types from .eaf or .etf files.
Click on Edit > Import types.... Here you can select a .eaf or .etf file by clicking on Browse. Select the file you want to use in the next window and click Select. Finally click Import to import the linguistic types from the selected file.

5.3.6. Associating a linguistic type with a Data Category

In ELAN it is possible to associate a linguistic type with a data category of the ISO Data Category Repository (DCR). To do so click on Type in the ELAN main menu and select Change Linguistic Type.... In the window that now appears, click the Browse... button to the right of the ISO Data Category option. In the next window (Figure 5.12), first select a profile in the left panel and then select a data category in the middle panel. Finally click on Apply to associate the selected data category to the linguistic type.

Figure 5.12. Local Data Category Selection

More information about the ISO DCR and how to use it can be found in Section 5.2.

5.4. How to define a tier and its attributes

ELAN offers the following options:

• adding a new tier (Section 5.4.1);
• changing the tier attributes (Section 5.4.3);
• deleting a tier (Section 5.4.4).

5.4.1. Adding new tiers

Do the following to add a new tier:

1. Click on Tier > Add New Tier.... The Add Tier dialog window appears.
2. Define the tier attributes:
Enter the following information:

1. Go to **Tier name**. Enter the tier name.
   
   The tier name is the name that is displayed in the Timeline, Interlinear and Subtitle Viewer.

2. Go to **Participant**. Enter the name of the participant whose utterance is being transcribed.

3. Go to **Parent tier**. Select a parent tier from the pull-down menu.
   
   - If the tier has no parent tier, select none.
   - Otherwise select the appropriate parent tier.

4. Go to **Linguistic type**. Select a linguistic type from the predefined list in the pull-down menu (see Section 5.3).

**Note**

The list of possible linguistic types is dependent on the parent tier that is chosen. E.g., if there is no parent tier ("none" in the pull down menu), the linguistic types to choose from are of the stereotype "none" (see Section 5.3).
5. Go to Default Language. Select the default character set from the pull-down menu. If you don’t change this, the system’s default language will be chosen.

Whenever you enter or change annotations on that tier, the text entry box is automatically preconfigured for the default character set.

6. Click the More Options… button if you would like to change the color of the tier name and the font of the annotations. In the new dialog window you can change them by clicking Browse…, selecting a color or font and clicking OK. To apply the new color and font click Apply.

Finally click Add to save the tier and its attributes. Otherwise click Cancel to exit the window without saving.

5.4.2. Importing tiers

You can reuse the tiers (together with their linguistic types) you created before in other eaf or etf (templates, see Section 4.2.9) files:

1. Select Tier > Add new tier…

2. Click on the Import tab

3. Click on Browse…

4. Select the eaf or etf file from which you want to import a tier and confirm your choice by clicking on Select

5. Finally click on Import.
Figure 5.14. Import tiers

![Import Tiers](image)

**Note**

If you import a linguistic type that already exists, a postfix like –cp1 or –cp2 will be added to the imported version.

### 5.4.3. Changing tier attributes

Do one of the following to change the attributes of an already existing tier:

1. Use the mouse.
   a. In the Timeline Viewer, right-click at about the height of the tier that you want to change. A pull-down menu appears.
   b. In the pull-down menu, click on **Change tier attributes**. The **Change tier attributes** dialog window for that tier appears.
c. Change the tier attributes in the dialog that now appears and confirm by clicking on Change.
Figure 5.16. Change tier attributes

Note

You can’t change the Parent Tier nor the Linguistic type in this dialog because of possible data loss this alterations would cause. To change these settings in a safe way (i.e. creating a copy of the tier and changing this copy) see Section 5.4.3 and Section 5.4.5.

2. Use the Tier menu.
   a. Click on Tier menu.
   b. Go to Change tier attributes…
   c. Click on the drop down box and select the tier which attributes you want to change. The Change tier attributes dialog window for that tier appears.
   d. After making the changes, click on Change to save them. Otherwise click Cancel to exit the window without saving.
5.4.4. Deleting tiers

Do one of the following to delete a tier:

1. Use the mouse.
   a. In the Timeline Viewer, right-click at about the height of the tier that you want to delete. A pull-down menu appears.
   b. In the pull-down menu, click on Delete tier.
2. Use the Tier menu.

   a. Click on Tier menu.

   b. Go to Delete tier… A dialog window appears.

   c. The labels of all available tiers are displayed a pull down box, e.g.:

   c. A warning dialog appears asking you to confirm the deletion (see below).
d. Click on the tier that you want to delete. A warning dialog appears asking you to confirm the deletion, e.g.:

**Figure 5.20. Deleting tier confirmation**

```
Do you really want to delete the tier tx?
Refering tiers are also removed:
☐ mb
☐ gl
☐ ps

[Yes] [No]
```

e. Click Yes to delete the tier and all its child tiers; click No to not delete them.
Note

If you delete a tier, you will lose all its annotations.

If you delete a parent tier, all its child tiers will be automatically deleted as well. Please make sure that you do not accidentally delete a child tier.

To delete a parent tier without deleting its child tiers, you have to assign the child tier to another parent or make it an independent tier. Afterwards you can safely remove the parent tier. For instructions on how to change a tier’s parent, see Section 5.4.5.

5.4.5. Changing the parent of a tier

Previous versions of ELAN offered an option to change the parent of a tier. As this operation could cause data loss when not performed carefully, this function has been disabled. However, what can be done now as an alternative is making a copy of a tier and altering that copy. This prevents the possible loss of data, as the original tier stays the same. At the same time the linguistic type of the copy can be changed as well. In order to maintain the overview during this potentially complicated operation a wizard guides you through this process, which can be started via the Tier > Change parent of tier... menu.

Note

Though an undo option is available it still is a good idea to make a backup of your files before proceeding.

Table 5.3. Change parent of tier wizard

1. Select the tier of which the parent should be changed

2. Select the new parent tier. Choose "Transcription" to make the copy an independent tier.
As the result of this process the selected tier (and its children) will be copied and they will become dependent upon the newly chosen parent tier. In our example the W-Words tier, previously a child of W-Spch, became an independent tier:

Figure 5.21. Dependant to independant tier

Note that as the tier is not moved but copied the names have been changed: a postfix “-cp” has been added to the copies. The original can be deleted afterwards if you are satisfied with the result of the operation, while the copies can be renamed to reflect the original tier names.

If you decide to assign a tier to a different parent tier, ELAN will automatically align its annotations with that of the new parent tier (based on overlapping time intervals). In this case, if there is an annotation on the referring tier, but no overlapping annotation on the parent tier, ELAN will delete this annotation. Be very careful that you do not lose such annotations accidentally. A referring tier can be turned into an independent time-alignable tier without any problem.

5.5. Controlled Vocabularies

5.5.1. The creation of a CV

When you frequently use a certain linguistic type with a limited number of annotation values, it might be a good idea to associate a Controlled Vocabulary (CV) with it. Such a CV consists of a number of predefined values that a user can choose from when editing an annotation, thus making the task of the annotator less error-prone. E.g. one can choose to create a controlled vocabulary for part of speech tagging, as the tags that are used often reoccur. In order to do this select Edit > Edit Controlled Vocabularies. The following dialog will appear:
Figure 5.22. Edit controlled vocabulary

To create a new CV, do the following:

1. Enter a CV Name and a description
2. Click on the Add button
3. Now enter each CV entry and its description.
4. Confirm every entry addition by clicking on the Add button or by hitting Enter

Note

The undo function in the CV dialog window only works as long as that window is active. Once it is closed changes cannot be undone anymore.

5.5.2. Associating a CV entry with a Data Category

In ELAN it is possible to associate an entry of a controlled vocabulary with a data category of the ISO Data Category Repository (DCR). To do so click on Edit in the ELAN main menu and select Edit Controlled
Vocabularies... In the window that now appears, click the Browse... button to the right of the ISO Data Category option. In the next window (Figure 5.23), first select a profile in the left panel and then select a data category in the middle panel. Finally click on Apply to associate the selected data category to the CV entry.

**Figure 5.23. Local Data Category Selection**

More information about the ISO DCR and how to use it can be found in Section 5.2.

### 5.5.3. Importing an existing CV

Instead of creating a Controlled Vocabulary again every time ELAN also supports the possibility to reuse existing CVs. A first way to achieve this is to use a template file that contains a CV when creating a new *.eaf file. (See Section 4.2.1) Alternatively you can import a CV for already existing files:

1. select Edit > Edit Controlled Vocabularies
2. Click on Import CV
3. Select the template from which you want to import a CV
4. Choose Open
5. Now all CVs that are stored in the selected template file will be imported

If you try to import a CV with the same name as an already existing CV a dialog will pop up asking what to do:
5.5.4. Exporting a CV

A CV can be exported by saving the current file as a template. (See Section 4.2.7)

5.5.5. Using CVs

When editing an annotation that belongs to a linguistic type associated with a CV, a drop down box appears. Just select the value to be filled in:

Figure 5.25. Controlled vocabulary drop down box

---

**Note**

It is possible to by-pass the controlled vocabulary constraints by holding shift and double clicking on the active annotation (right clicking and selecting “Modify annotation value” while holding shift does the same).

**Note**

If a CV entry is associated with a data category of the ISO DCR (see Section 5.5.2), the annotation is also associated with that data category.
5.5.6. Associating a linguistic type with Controlled Vocabularies

Open the Change the Linguistic type dialog (via Type > Change linguistic type) and make a choice from the Use Controlled Vocabulary dropdown box:

Figure 5.26. Change linguistic type

5.6. How to make a selection

In order to make an annotation, you first have to select a time interval. ELAN supports the following options:

- making and saving a selection on an independent tier (Section 5.6.1);
- making and saving a selection on an independent tier while playing (Section 5.6.2);
- making and saving a selection on a referring tier (Section 5.6.4);
- deselecting a selection (Section 5.6.5);
- changing the time alignment of an existing selection (Section 5.6.6);
- activating and deactivating the Bulldozer mode (Section 5.6.7).

5.6.1. Making a selection on an independent tier

To make a selection, do the following:
1. Go either to the Waveform or the Timeline Viewer.

2. Go with the mouse to the beginning of the time interval you want to select.

3. Click the mouse button, keep it clicked and drag it to the endpoint of the time interval you want to select.
Figure 5.27. Making a selection

The video image will be continuously updated. The selected part is highlighted in light blue color.

The selection can be extended beyond the size of the current window. The display in all Viewers will automatically move along.
You can change the beginning and endpoints of the selection. Choose one of the following options:

1. Either use the mouse: press the key Shift, keep it pressed and click with the mouse to the left/right of the selected part. The selection will be extended to include this point.

2. Or enable the Selection Mode by selecting the Selection Mode checkbox. When selection mode is enabled, you can use the media controls to edit the selected part. When moving the crosshair in Selection Mode, the current selection is narrowed or broadened, depending on the direction the crosshair is moved to. For a complete overview of the use of the media controls, see Section 4.3.11.

Figure 5.28. Change selection

5.6.2. Using the selection controls

The selection controls allow you to navigate through or to change the active selection. For their use, see again Section 4.3.11.

Example: extending the begin of a selection with one second

Assume that you have made a selection and that you want to add a time interval of 1 second to the begin of it. In that case you should perform the following actions:

1. Move the crosshair to the begin of the active selection
2. Enable Selection Mode

**Figure 5.30. Selection mode**

The crosshair has moved to the begin of the selection

Selection mode is enabled

3. Go back one second by clicking the corresponding button from the media controls.

**Figure 5.31. Back one second**

This button broadens the selection with 1 second in selection mode

4. Turn off the selection mode and enter an annotation for the selection.
5.6.3. Creating annotation units without gaps

It is possible to start a new selection immediately after a previous selection has ended, i.e., the endpoint of one selection will be taken as the starting point for the next selection. Do the following:

1. Make a selection on an independent tier (see Section 5.6.1).

2. Double-click on the selection.

3. Optionally enter the content of the annotation unit. Press the keys **CTRL+ENTER**. The selection is saved.
Figure 5.33. Annotation without gaps (steps 1-3)

4. Press the keys ALT+SHIFT+C or click on the clear selection icon to deselect the selection (see Section 5.6.5 for deselecting a selection).
5. Enable the selection mode. Then, play the video or sound file until the playback stops. The new selection extends from the endpoint of the previous selection until the point when the playback was stopped.

Repeat steps 2 and 3 to save the new selection.

Repeat steps 3 to 5 to add another selection.
5.6.4. Making and saving a selection on a referring tier

A referring tier inherits all its time alignments from its parent tier. To make and save a selection on a referring tier, do the following:

1. Select and save a time interval on the corresponding parent tier (see Section 5.6.1 and Section 5.7).

2. Double-click somewhere within the time interval of the parent annotation at about the height of the referring tier. The Inline Edit box appears.
3. Do one of the following:
   a. Enter an annotation (see Section 5.7), and then press the keys CTRL+ENTER to save the selection.
   b. Press the keys CTRL+ENTER (without entering an annotation) to save the selection.

### 5.6.5. Deselecting a selection

To deselect a selection, do one of the following:

1. Either use the Deselection icon from the selection controls.
2. Or use the shortcut key ALT+SHIFT+C.

**Note**

Whenever you select another time interval, the old selection is automatically deselected, unless you enabled Selection Mode.

### 5.6.6. Changing the boundaries of an existing selection

**By selection**

In the timeline viewer, go through these steps:

1. Click on an annotation unit to select it.
2. Select the region where you want the modified annotation to be placed.

**Figure 5.38. Region for modified annotation**

3. Right click on the original annotation and select Modify annotation time or press **CTRL+ENTER**

**Figure 5.39. Modify annotation time**

4. Now the length of the annotation becomes that of the selection from the second step.

**Figure 5.40. Annotation length changed**

### By dragging the mouse

If you press ALT, the active annotation is indicated in green and becomes adjustable with the mouse:

- drag in the middle of the annotation and drop it somewhere else to move it
- drag and drop the borders to change the boundaries of the annotation unit
Figure 5.41. Changing selection boundaries by mouse

Move the annotation

Change the annotation boundaries

Note

Only the time-alignment of annotations on the following types of tiers can be modified: annotations on independent tiers, and annotations on referring tiers that fall under the Time Subdivision stereotype (but note that in the latter case, the alignment cannot be extended beyond the boundaries of its parent annotation, see Section 5.1). To modify the time alignment of annotations on all other tiers, change the time alignment on the corresponding parent tier (following the steps above). The time alignment on all referring tiers is automatically updated.

5.6.7. Activating and deactivating the Bulldozer mode or Shift mode

ELAN supports three editing modes: Overwrite mode, Bulldozer mode, and Shift mode. These modes are somehow comparable to the Overwrite and Insert modes that are supported by many text editor programs such as, e.g., Microsoft Word.

- Normal (i.e. overwrite) mode: if you extend a selection into a time interval that is already occupied by an annotation, that annotation is (partly or wholly) overwritten.

Figure 5.42. Normal mode

- Bulldozer mode: if you extend a selection into a time interval that is already occupied by an annotation, that annotation is moved to the right/left. Think about it as a bulldozer which pulls all annotations together, discarding the spaces in between.
Figure 5.43. Bulldozer mode

- Shift Mode: like Bulldozer Mode, but the spaces between annotations are preserved too. This resembles most to the insert mode of text editors.

Figure 5.44. Shift mode

The following conventions apply for the Bulldozer mode:

- Annotations are moved to the right if you extend your selection from left to right. They are moved to the left if you extend your selection from right to left.

- If a moved annotation extends into the time-interval of yet another annotation, that other annotation is moved accordingly. If it extends into empty space, no other annotations are affected.

Note

Moving annotations may thus affect the whole document, and may thereby destroy previous time alignments. Please make sure that the Bulldozer Mode is not accidentally switched on.

The Overwrite mode is the default mode. To switch to another mode, do the following:

1. Click on Options > Propagate Time Changes.

2. Click on Normal Mode, Bulldozer Mode or Shift Mode. A checkmark appears next to it. To switch back to the Overwrite mode, repeat steps 1 and 2 above. The checkmark disappears.

5.7. How to enter annotations

All annotations are entered either into the Inline Edit box or into the Edit Annotation box, which are accessed via the Timeline, Interlinear, Grid, Text and Subtitle Viewers. ELAN supports the following options:

- entering annotations (section Section 5.7.1 and Section 5.7.2);
- entering annotations before/after other annotations (Section 5.7.3);
- modifying the content of annotations (Section 5.7.8);
• deleting annotations (Section 5.7.10);
• entering annotations in different character sets (Section 5.7.11).

5.7.1. Entering annotations (into the Inline Edit box)

5.7.1.1. An Inline Edit box from a selection

1. Select the time span in which you want to place the annotation.

2. Access the Inline Edit box by doing one of the following:
   a. Either double-click in the Timeline Viewer on the selection at about the height of the tier where you want to enter the annotation.
   b. Or click on Edit menu, then click on New annotation here (active tier only).
   c. Or use the key equivalent ALT+N (active tier only).

   In all cases, the Inline Edit box appears, e.g.:

   Figure 5.45. Inline Edit box

   ![Inline Edit box](image)

3. Do one of the following:
   a. Press the keys CTRL+ENTER (without entering an annotation) to create an empty annotation.
   b. Enter an annotation and then press the keys CTRL+ENTER to save the selection.

   It is possible to enter text that contains line breaks. The text entry box automatically displays a scrollbar if necessary.

   The Inline Edit box is automatically preconfigured for the default character set of the tier. If you want to use a different character set, do the following:
   i. Right-click in the Inline Edit box. A pull-down menu appears that displays the available character sets.
ii. Click on the appropriate character set. From now on, the characters are entered in the selected set.

Note

If you are using a third-party keyboarding solution like Keyman, make sure to select the default system language as input language for the tier to be edited (e.g. Dutch if your system language is set to Dutch).

iii. To switch back to the default character set, repeat the steps above and select the default set from the pull-down menu.
4. Save the annotation by doing one of the following:
   a. Use the shortcut keys `CTRL+ENTER`.
   b. Or right-click in the Inline Edit box and click on Commit Changes in the pull-down menu.

To exit the Inline Edit box without saving, do one of the following:
1. Use the shortcut key ESC.
2. Or right-click in the Inline Edit box and click on Cancel Changes in the pull-down menu.

### 5.7.1.2. An Inline Edit box from begin and endtime

An alternative method to get an Inline Edit box is:
1. Click a time that should become the begintime of the annotation.
2. Press `SHIFT+ENTER`.
3. Click a time that should become the endtime of the annotation.

An Inline Edit box appears on the selected tier. You can now enter an annotation and save it in the way explained above.

### 5.7.2. Entering annotations (into the Edit Annotation box)

The Edit Annotation box differs from the Inline Edit box in that it has a bigger, resizable, display and supports line wrapping. It is therefore better for entering longer texts.

To enter an annotation into the Edit Annotation box, do the following:
1. Either make a selection in the Timeline Viewer (see Section 5.6.1), or click on an existing annotation in the Timeline or Interlinear Viewer.
2. Access the Inline Edit box (see Section 5.7.1).
3. Do one of the following:
   a. Either use the shortcut keys `SHIFT+ENTER`.
   b. Or right-click in the Inline Edit box. A pull-down menu appears. Click on Detach Editor.
4. The Edit Annotation box appears:
The **Edit Annotation** box is automatically preconfigured for the default character set of the tier (see Section 5.4.3). If you want to use a different character set, do the following:

a. Click on **Select Language**. A pull-down menu appears that displays the available character sets, e.g.:
5. Edit the annotation.

6. Save the annotation by doing one of the following:
   a. Use the shortcut keys CTRL+ENTER.
b. In the Edit Annotation box, click on Editor and then click on Commit Changes in the pull-down menu.

To exit the Edit Annotation box without saving, do one of the following:

1. Use the shortcut key ESC.

2. In the Edit Annotation box, click on Edit and then click on Cancel Changes in the pull-down menu.

To return to the Inline Edit box, do one of the following:

1. Use the shortcut keys SHIFT+ENTER.

2. In the Edit Annotation box, click on Attach Editor in the pull-down menu.

### 5.7.3. Entering annotations before/after other annotations

Annotations on some tiers can be subdivided into smaller units. In this way, you can for example break up a sentence into different words (or words into morphemes, etc.), as in the following illustration:

**Figure 5.49. Subdividing annotation**

To divide an annotation into smaller units, do the following:

1. In the Timeline or Interlinear Viewer, click on the annotation that you want to subdivide. It appears in a dark blue frame.

2. Do one of the following:

   a. Right-click on the selected annotation. A pull-down menu appears. Click on either New Annotation before or on New Annotation after to subdivide the annotation.

   b. Or click on Edit menu. Then click on either New Annotation before or on New Annotation after to subdivide the annotation.

If you click on **New annotation before**, the original annotation is divided and the new annotation is inserted to its left (as in the illustration below). If you click on **New annotation after**, it is inserted to its right.
An annotation is always subdivided into two units. If you need further subdivisions, repeat the steps above.

### 5.7.4. Creating regular annotations

When there is a time interval you wish to divide in a number of adjacent annotations with the same duration you can do that by clicking on Tier > Create Regular annotations. In the dialog window (see Figure 5.51) select the tiers that must receive the new annotations. Then do one of the following:

1. Enter Start time and Duration (End time is calculated automatically).
2. Enter Start time and End time (Duration is calculated automatically).

Finally, enter a Annotation size and click Apply.
Figure 5.51. Regular Annotations

The total duration of the new annotations does not exceed the interval between start and end time. So if start time is 1.000 seconds and, end time is 4.000 seconds (interval of 3 seconds) and the annotation size is 2.000 seconds, than only one new annotations is created because two would make a duration of 4 seconds which exceeds the interval defined by the start and end time.

**Note**

If there is an overlap between the new annotations and one or more existing annotations, these existing annotations will be removed.

### 5.7.5. Duplicating annotation values

If two annotation are adjacent and have the same length (for instance after creating regular annotations, see Section 5.7.4) and if the second annotation is empty, you can copy the value of the first annotation to the second. This is done by selecting the first annotation and pressing `CTRL+SHIFT+D`. Now the second annotation is selected and you can repeat the process to get a string of adjacent annotations with the same value.

An additional result of `CTRL+SHIFT+D` is that if there are annotations on another tier that have the same begin and endtime as the annotations you are working on, and the second of those annotations is empty, then the value of the first annotation on that tier is also copied to the second annotation on that tier.

### 5.7.6. Automatic labeling and numbering

Sometimes you don't want annotation to contain transcriptions of the media you are working on, but you rather want to label and number them for later processing. In ELAN this is accomplished by clicking Tier > Label And Number Annotations.... In the dialog as shown in Figure 5.52 you can select one or more tiers to provide labels and numbering.
Figure 5.52. Label and Numbering annotations

The formatting options of the label and numbering include:

- Include label part: the text to act as label (or prefix) for each annotation.
- Insert delimiter: a delimiter between the label in front and the number.
• Include number part:
  – Integer: the number of each annotation is an integer and the increment value is also an integer.
  – Decimal: the number of each annotation is a decimal and the increment value can also be a decimal.
• Prepend leading zeros: leading zeros for easy sorting in post-processing (e.g. 001, 002, 003 etc).
• Start value: the value the numbering must start with.
• Increment: the value with which the number in the next annotation is incremented.

The result of the options is shown below the options in a blue box. This result is updated as you change the options.

5.7.7. On-the-fly segmentation

Creating annotation units can be a time consuming job. Therefore, ELAN offers a faster way to initially mark the boundaries of annotation units on a root tier (i.e. where the linguistic type stereotype is “None”): on-the-fly segmentation. This way of working is similar to Transcriber’s segmentation mode. This mode can be accessed through Tier > Segmentation … and works as follows:

1. Select the tier to be segmented

2. Choose between two keystrokes/annotation (non-adjacent annotations), one keystroke/annotation (this makes all annotations adjacent) and one keystroke/annotation, fixed duration (specify the duration and whether the keystroke marks the begin or end of an annotation).

3. Use the media controls to play the media file or use the keyboard shortcuts (see Section 7.2.2).

4. Press enter to start/end an annotation unit, while the movie or sound file is playing

5. Once finished, choose Apply to save the newly created annotations or Cancel to discard the changes.

Note

The segmentation is considered as a single operation and thus can be reversed by a single undo command.

1See http://www.etca.fr/CTA/gip/Projets/Transcriber/
5.7.8. Modifying the content of annotations

To modify an annotation, do one of the following:

1. In the Timeline or Interlinear Viewer:
   a. Click on the annotation that you want to modify. It appears in a dark blue frame.
   b. Do one of the following:
      i. Right-click on the selected annotation. A pull-down menu appears. Click on Modify annotation value.
      ii. Or click on Annotation > Modify annotation value.
      iii. Or use the key equivalent ALT+M. 

      The Inline Edit box appears (see Section 5.7.1).

2. In the Grid Viewer:
5.7.9. Deleting annotation values

To delete the value of annotation, do the following:

1. In the Timeline or Interlinear Viewer, click on the annotation from which you want to delete the value. It appears in a dark blue frame.

2. To delete it, do one of the following:
   a. Right-click on the selected annotation. A pull-down menu appears. Click on Remove Annotation Value.
   b. Or click on Edit menu. Then click on Remove Annotation Value.
   c. Or use the key equivalent ALT+Delete.

The annotation value is deleted without further warning.

5.7.10. Deleting annotations

To delete an annotation, do the following:

1. In the Timeline or Interlinear Viewer, click on the annotation that you want to delete. It appears in a dark blue frame.

2. To delete it, do one of the following:
   a. Right-click on the selected annotation. A pull-down menu appears. Click on Delete annotation.
   b. Or click on Edit menu. Then click on Delete annotation.
   c. Or use the key equivalent ALT+D.

   Note

   The annotation is deleted without further warning.

   If you delete an annotation on a parent tier, the corresponding annotations on all its child tiers will be automatically deleted as well. Please make sure that you do not accidentally delete a child annotation. An annotation on a child tier can be deleted without consequences for the annotation on its parent tier.

5.7.11. Entering annotations in different character sets

ELAN supports different character sets, making use of the following input methods:

1. GATE Unicode Kit (GUK)

   Characters can be entered by using a different keyboard mapping. This method is implemented using the GATE Unicode Kit developed at Sheffield University, Department of Computer Science.

   If you select a character set that is based on GUK, a visual representation of a keyboard appears on the screen, which informs you about the implemented keyboard mapping. The following illustrations show the mappings of “ipa-96 (SAMPA)” and “Arabic (WINDOWS)”:
To enter a character, do one the following:

a. Either press the corresponding key on your keyboard.

b. Or click on the corresponding key of the keyboard displayed on your screen.

The visual representation has the layout of the standard UK keyboard. If you do not have a UK keyboard, there may be mismatches between the characters and their visual representation.

For example, the IPA character “#;” is matched to the key “@”, i.e., in order to get “#”, you have to type “@”. On a standard UK keyboard, the key “@” is located to the left of the key “enter” (see the illustration above). On other keyboards, however, “@” may be located on a different key. In such cases, if you press the key to the left of “enter”, you will not get the character “#”. To get “#”, you have to search for the location of “@” on your keyboard, and then press that key. (Note that these mismatches only arise if you use the physical keyboard, but not if you use the visual representation on the screen.)

The character set “ipa-96 (SAMPA)” can be used to enter IPA characters. However, the current version of ELAN only supports SAMPA, but not X-SAMPA. As a consequence, some of the characters that you require may not be available yet (see http://www.phon.ucl.ac.uk/home/sampa for further information).
2. Roman Typographic Root (RTR)

IPA characters can be entered using the RTR input method. This method is based on the following principle: whenever you type a character, all typographically similar characters are displayed in a lookup list, as shown in the following illustration:

**Figure 5.56. Roman typographic root**

To select a character from the lookup list, do the following:

a. Use the UP and DOWN arrow keys to navigate to the desired character.

b. Press ENTER or SPACE to confirm the selection.

---

**Note**

*Do not* use the mouse within the lookup window. If you do, the window will disappear.

The input of IPA characters is restricted to the official IPA-96 character set. Withdrawn or superseded characters are not supported.

The RTR-mapping is generally obvious, but please pay attention to the following features:

- Use lower case letters only.

- IPA characters can map to non-letter symbols, e.g.:
Diacritics are entered with the help of the following keys:

**Table 5.4. Diacritics**

<table>
<thead>
<tr>
<th>key</th>
<th>position of diacritic in relation to character</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;</td>
<td>(quotation mark) above</td>
</tr>
<tr>
<td>'</td>
<td>(apostrophe) in the upper right</td>
</tr>
<tr>
<td>:</td>
<td>(colon) to the right</td>
</tr>
<tr>
<td>'</td>
<td>(grave accent) in the lower right</td>
</tr>
<tr>
<td>^</td>
<td>(circumflex accent) under</td>
</tr>
<tr>
<td>`</td>
<td>(tilde) on</td>
</tr>
</tbody>
</table>

For example:
Figure 5.58. Diacritics

Note

On Windows 2000, if you use an international keyboard, you have to type SPACE after typing the quotation mark ("') or one of the accents (', `, ^).

It is possible to stack diacritics, but there may be problems displaying them.

3. Chinese characters

Chinese characters, both traditional and simplified, are entered using the Pinyin method. Characters are selected by starting to type Roman characters. Candidates are shown in a lookup window while the user types along. The desired character is selected with the UP and DOWN arrow keys, e.g.:
Use the following procedure:

• Enter the pinyin word with the keyboard. For each pinyin word, a list of Han symbols is shown in a popup window.

• Navigate to a Han symbol with the UP and DOWN arrow keys.

• Page through the list with the PAGE UP and PAGE DOWN keys.

• Select a Han symbol with the SPACE or the ENTER key.

Note

Do not use the mouse within the lookup window. If you do, the window will disappear.

On Windows 98, you cannot display both Chinese and IPA characters.

4. Keyboard tools

If the options above don’t fulfill your needs (e.g. the character set is not supported or you don’t want to use the on-screen display for a large amount of annotations) you might want to look for a third-party solution. Such a tool provides a mean to remap your keyboard to the desired input character set. For details, we refer to the following programs:

Keyman (Windows), http://www.tavultesoft.com/
Figure 5.60. Keyman

Ukelele (Mac), http://scripts.sil.org/ukelele

Figure 5.61. Ukelele

Note

If you are using a third-party keyboarding solution like Keyman, make sure to select the default system language as input language for the tier to be edited (e.g. Dutch if your system language is set to Dutch).

5.7.12. Associating an annotation with a Data Category

In ELAN it is possible to associate an individual annotation with a data category of the ISO Data Category Repository (DCR). To do so first select an annotation. Then click Annotation in the main menu of ELAN and select Modify Annotation Data Category (alternatively press ALT-SHIFT-M). In the next window (Figure 5.62), first select a profile in the left panel and then select a data category in the middle panel. Finally click on Apply to associate the selected data category to the annotation.
5.8. How to create annotation units on dependent tiers

One of the main advantages of using a hierarchical structured tiers is the possibility to split the content of an annotation unit on a parent tier automatically into smaller parts on a child tier. E.g. the words on an utterance tier could be split into separate words. This is called tokenizing in Elan. These steps will guide you through this process:

1. Go to Tier > Tokenize tier

2. Select a Source (= parent) and Destination (= child) tier

3. Optionally create a new destination tier by selecting Create New Tier…

4. Select a delimiter. The default is a space, but other choices are possible (e.g. “-” for morpheme breaks).

5. If the destination tier already contains annotation units, choose between overwriting or preserving them. If it’s still empty you can ignore this option.

6. Select Create destination annotation for empty source annotation if you want to create for every source annotation a destination annotation, even if it’s empty.
Figure 5.63. Tokenize tier

7. Click on Start, the tokenization will begin:

Figure 5.64. Tokenization

8. When it is finished, you will see that every annotation unit from the source tier has been tokenized on the destination tier:
Even when tokenizing to a tier from the type time subdivision, all tokens (words in this example) on the destination tier have the same size (i.e. duration). In that case you probably want to adjust their length, as described in Section 5.6.6.

For symbolic associations, there is no need to use the tokenizer. Instead, go to the grid viewer and make sure the checkbox next to the dropdown menu is selected. Now you can fill in the annotations of the symbolic associations in their column of the grid. See also Section 4.3.6. If you want to copy or filter the contents from 1 tier to another symbolic associated tier, have a look at Section 5.9.

Tabs and newline characters are always treated as delimiters.

5.9. How to filter and copy tiers

5.9.1. Filtering tiers

Filtering a tier (Tier > Filter Tier…) works in a very similar way as the previously described tokenizer. The main difference is that filtering is meant for transfer of annotation information between tiers that are symbolic associations.

A step-by-step approach to filtering:

1. Select a source tier (from which the information will be copied)
2. Choose a destination tier. If necessary create a new tier (with the Create new tier… button)
3. Optionally specify a filter. If a filter expression is found, it will be removed from the destination annotation. Without any filter, the complete source tier is copied to the destination tier.
4. If the destination tier already contains annotation units, choose between overwriting or preserving them. If it’s still empty you can ignore this option.
5. Select Create destination annotation for empty source annotation if you want to create for every source annotation a destination annotation, even if it’s empty.
6. Click on Start to begin the filter operation or Close to go back to ELAN’s main screen.
5.9.2. Copying tiers

Like you can change the parent of a tier, it also is possible to copy the complete content of a tier. This option differs in that it does not put any constraints on the designated parent tier and it leaves you the choice whether you want to copy the tier’s children.

This process can be started via the Tier > Copy tier menu. Follow the steps below:

1. Choose a tier to copy. If you also want to create a copy its dependent tiers, check the Copy dependent tiers as well box.

2. Specify the parent tier for the copy. To make it independent, select Transcription (no parent).

3. By default, the linguistic type will be kept. If you want to change it, select another one from the dialog window and click on Finish.

4. Now the tier (and optionally its children) will be copied. “-cp” will be added to the names in order to prevent confusion with the original tier.

Note that this is similar to the change parent tier functionality (see Section 5.4.5). However it differs in 2 aspects:

• It is not mandatory to copy the child tiers.

• The parent for the copy can any be tier in the transcription, including the tier itself.
5.10. How to detect annotation overlaps

In some cases you might want to have more information about annotation overlaps and their respective duration. For this purpose a wizard has been developed that automatically detects these annotation overlaps and optionally adds the length of the overlaps to the newly created annotations.

This function can be started from Tier > Create Annotations from Overlaps…. This will give you the following dialog windows:

Figure 5.67. Create annotations from overlaps

1. Select the tiers for which overlaps should be found.
2. Click on Next
3. Enter a name for the new tier and select its linguistic type
4. Optionally let the created annotations be filled with the overlap duration
5. Click on Finish. Now the new tier will be created and populated.
5.11. Copy and paste annotations

5.11.1. Copy annotation

Just like in many other applications, you can reuse elements you are editing with the well-known copy and paste operations. To copy an annotation do the following:

1. Select the annotation

2. Right click on it and select Copy Annotation, select the same option in the Annotation drop-down menu or press CTRL+C

By default only the selected annotation will be copied. If you want the annotation including all its child annotations (those on the dependent tiers) to be transferred as well, select Copy Annotation Group and Paste Annotation Group.

5.11.2. Paste annotation

In a similar way you can paste these annotations from the clipboard into ELAN:

1. Go to the tier where you want to paste the annotation

2. Select Annotation > Paste Annotation or press CTRL+V

Note

Annotations can only be pasted onto tiers of the same linguistic type! If you want to copy the annotation to a tier of a different type, use Duplicate Annotation (see Section 5.11.4).

Please note that pasting an annotation can result in different behavior according to the context:

- By default the annotation is pasted onto the tier where it originates from.

- If that is impossible (i.e. there is no tier with the same name as the originating tier, e.g. in another file) the copy of the annotation will be placed on the active tier (see Section 7.1.3 on how to activate a tier)

However, pasting an annotation will never change the time alignment of that annotation unit. This means that the annotation will be placed on exactly the same time as it was found when the copy operation was performed. If you want to change its timing, move it afterwards or use the Paste annotation here option (see Section 5.11.3).

5.11.3. Paste annotation here

Using this function (Annotation > Paste annotation here or press CTRL+SHIFT+V) you can copy an existing annotation to any tier and time you want. (Of course the tier still has to belong to the same linguistic type). The copy will be placed on the position of the crosshair on the active tier.

Right click somewhere in the timeline viewer and select Paste annotation here from the context menu to copy the annotation to the position of the mouse cursor – both the tier and the time position.

5.11.4. Duplicate annotation

Select an annotation and make the tier where you want it to be duplicated the active tier. Now select Annotation > Duplicate Annotation or press CTRL+D to create an exact copy of the annotation onto the active tier. This function also works for tiers that don't share the linguistic type.
5.11.5. Synopsis

Figure 5.68. Synopsis copy and paste annotations

### Duplicate

File A → File A

### Copy / Paste

File A → File B

### Copy Group / Paste Group

File A → File B

### Copy / Paste Here

File A → File A or File B

### Copy Group / Paste Group Here

File A → File A or File B

5.12. How to undo an action

Most actions in Elan can be undone via the Edit > Undo (or CTRL+Z) menu. A redo (go back to the state before the undo action) is available to, via Edit > Redo (or CTRL+Y).

The following commands support undo/redo:

- Add new tier / linguistic type
- Copy tier / change parent tier
5.13. Information about annotations

5.13.1. Annotations Spreadsheet

A very basic view of the annotations in the independent tiers can be obtained by clicking on View > Annotations Spreadsheet. This option simply lists all annotations of all independent tiers ordered by time.

5.13.2. Annotations Statistics

ELAN offers a possibility to compute some statistics of the independent tiers. Click on View > Annotations Statistics and select a tier in the dialog window:

Figure 5.69. Annotations Statistics
The Annotations tab shows the following information:

- Annotation
- Occurrences: the number of occurrences (contiguous annotations containing the same value count as only one occurrence).
- Frequency: the frequency defined as the number of occurrences divided by the observation period.
- Average Duration: the average duration defined as the total duration of the annotations containing the same value divided by the number of occurrences.
- Time Ratio: the time ratio defined as the total duration of the annotations containing the same value divided by the observation period.
- Latency: the latency defined as the time interval between the beginning of the observation period and the first occurrence of an annotation.

The *observation period* is the interval between the beginning of the first annotation of all tiers and the end of the last annotation of all tiers.

The Tiers tab shows:

**Figure 5.70. Tiers statistics**

<table>
<thead>
<tr>
<th>Tier</th>
<th>Number of Annotations</th>
<th>Minimal Duration</th>
<th>Maximal Duration</th>
<th>Average Duration</th>
<th>Median Duration</th>
<th>Total Annotation Duration</th>
<th>Latency</th>
</tr>
</thead>
<tbody>
<tr>
<td>K-Spch</td>
<td>7</td>
<td>0.36</td>
<td>1.04</td>
<td>0.652857</td>
<td>0.47</td>
<td>4.57</td>
<td>0.28</td>
</tr>
<tr>
<td>W-Spch</td>
<td>16</td>
<td>0.679</td>
<td>5.47</td>
<td>1.962667</td>
<td>1.86</td>
<td>29.74</td>
<td>0.78</td>
</tr>
<tr>
<td>YW-Vords</td>
<td>97</td>
<td>0.07</td>
<td>0.81</td>
<td>0.306593</td>
<td>0.26</td>
<td>29.74</td>
<td>0.78</td>
</tr>
<tr>
<td>YW-POS</td>
<td>97</td>
<td>0.07</td>
<td>0.81</td>
<td>0.306593</td>
<td>0.26</td>
<td>29.74</td>
<td>0.78</td>
</tr>
<tr>
<td>YW-IPA</td>
<td>15</td>
<td>0.679</td>
<td>5.47</td>
<td>1.962667</td>
<td>1.86</td>
<td>29.74</td>
<td>0.78</td>
</tr>
<tr>
<td>YW-RGU</td>
<td>1</td>
<td>33.84</td>
<td>33.84</td>
<td>33.84</td>
<td>33.84</td>
<td>33.84</td>
<td>0</td>
</tr>
<tr>
<td>W-RGph</td>
<td>59</td>
<td>0.12</td>
<td>1.48</td>
<td>0.573569</td>
<td>0.56</td>
<td>33.84</td>
<td>0</td>
</tr>
<tr>
<td>YW-ROMe</td>
<td>19</td>
<td>0.2</td>
<td>1.40</td>
<td>0.561053</td>
<td>0.56</td>
<td>11.04</td>
<td>1.6</td>
</tr>
<tr>
<td>K-RGU</td>
<td>1</td>
<td>0.92</td>
<td>0.92</td>
<td>0.92</td>
<td>0.92</td>
<td>23.12</td>
<td></td>
</tr>
<tr>
<td>K-RGph</td>
<td>3</td>
<td>0.24</td>
<td>0.4</td>
<td>0.306667</td>
<td>0.28</td>
<td>23.12</td>
<td></td>
</tr>
<tr>
<td>K-RGMe</td>
<td>1</td>
<td>0.28</td>
<td>0.28</td>
<td>0.28</td>
<td>0.28</td>
<td>23.52</td>
<td></td>
</tr>
<tr>
<td>test</td>
<td>1</td>
<td>2.21</td>
<td>2.21</td>
<td>2.21</td>
<td>2.21</td>
<td>2.21</td>
<td>2.23</td>
</tr>
</tbody>
</table>

- Tier: the name of a tier.
- Number of Annotations: the number of annotation on that tier.
- Minimal Duration: the minimal duration of an annotation on that tier.
- Maximal Duration: the maximal duration of an annotation on that tier.
- Average Duration: the average duration of the annotations on that tier.
• Median Duration: the median duration of the annotations on that tier.

• Total Annotation Duration: the total duration of all annotations on that tier.

• Latency: the time interval between the beginning of the observation period and the first annotation on that tier.

The *observation period* on the Tier tab is the interval between the begin and the end of the media.
Chapter 6. Searching

The ELAN tool allows you:

• to search annotations within one document (see Section 6.1)
• to display the results (see Section 6.2)
• to jump to the corresponding annotation the ELAN window (see Section 6.3)
• to search through multiple annotation files (see Section 6.4)
• to do a structured search through multiple annotations files (see Section 6.5)

6.1. Searching in a single annotation file

To search for text, do the following:

1. Click on Search menu.

2. Go to Find (And Replace)... (alternatively you can press CTRL+F) The following dialog window is displayed:

   Figure 6.1. Search dialog

3. The following search options are available:

   a. Go to Annotation on tier and, from the pull-down menu, select the tier to be searched.

   b. Go to matches and type in the item to be searched. If the linguistic type of the selected tier has a Controlled Vocabulary (see Section 5.4.5), this field is a pull down menu containing the entries of the controlled vocabulary. Note that it is still possible to enter a string that is not in the list.

   You can always make use of regular expressions to conduct your searches when “regular expression” is checked. (see Appendix A for the regular expression syntax).

   By default the search is not case sensitive. To change this, select the “case sensitive” checkbox.

   Optionally, specify the interval to search in (from ... s ...ms to ... s ... ms). Make a choice between searching within a time interval and finding annotations that overlap with a certain interval. Click on Add new constraint to add a second tier and search item. Up to 10 constraints can be used. There exist 2 kinds of them:

   1. Constraints based on structural distance. (Annotation units “around” a certain annotation entity). This option is only available for tiers that are symbolically associated to (or are a symbolical subdivision of) the tier mentioned in the first search box.

   For example: annotations contained in a structural distance of –1 to 2 tx-annotations from trees on the tier tx are sees, trees, and, flowers.

   Table 6.1. Annotation example

<table>
<thead>
<tr>
<th>tier</th>
<th>annotations</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>He sees trees and flowers.</td>
</tr>
</tbody>
</table>
2. Constraints based on temporal distance. This means search results are restricted on the basis of the temporal relation between two intervals:

- **is inside**: the annotation is completely contained within a given interval

- **overlaps**: at least a part of the annotation is contained within the given interval

- **overlaps only begin time of**: the annotation only has its end part in common with the given interval

- **overlaps only end time of**: the annotation only has its begin part in common with the given interval

- **is within ... around**: the annotation is contained in an interval around either the begin time or the end time

- **is within ... around begin time of**: the annotation is contained in an interval around the begin time
- *is within ... around end time of*: the annotation is contained in an interval around the begin time

It is possible to search on different tiers within one annotation. For example, the search parameters illustrated below search for all annotations on the tier tx, which contain “-s” in one of their morpheme breaks and “N” in one of their parts of speech. (Both “-s” and “N” are in distance of “0 words”, i.e., they occur within the same word as specified on the tier tx.) I.e., these parameters would find “trees” and “flowers” in the above example, but not “sees”.

**Figure 6.2. Find with constraints**

Another option is searching for sequences of utterances, words or other annotations on the same tier, e.g.:

**Figure 6.3. Find sequences**

You can delete the second (or third) search item. Click on **Delete last constraint** to delete it.
3. Right click in a text box to change the input character set and select the suitable language from the pull-down menu.

You only need this option if you want to select a non-default character set. The box automatically displays the default set of the selected tier (see Section 5.4.3).

After you have specified your search parameters, click OK to start the search process.

**Note**

Make sure the box next to Regular Expression is checked when you search for “special” characters (i.e. all characters that are not plain letters or digits) like diacritic characters.

### 6.1.1. Advanced searching: an example

Suppose we are investigating turn taking and we want to find all switches from speaker W to speaker K that don’t overlap, with gaps of at most 2 seconds. In order to find this, we fill in the search form as follows:
Figure 6.4. Advanced searching example

6.2. Displaying search results

After the Search is completed, ELAN displays the following search results:

- The number of annotations where the search item was found.
- The full content of each annotation where the search item was found.
- The begin, end time and duration of each annotation where the search item was found. To see more information per match, right click in the results and check the other desired fields (file – tier – before – after ).
6.2.1. The search history

When performing multiple search actions one after another, a search history is created. With this feature it becomes possible to browse through all the entered queries:

1. Enter a query and click OK to activate it.
2. Click on the New Query icon
3. Enter another query and choose OK
4. Now you can use the back and forward icons to browse through the search history.
Note

When closing the search dialog, the query history is removed. If nonetheless you want to save a certain search command, have a look at Section 6.2.3.

6.2.2. Refining a search

After a search operation, one can perform another search within the results of the previous action. To achieve this, select Search on current result from the Query menu in the Search dialog window. This will get you the following window:

Figure 6.7. Refining a search

By specifying extra search constraints, you can narrow down the results. This is similar to the addition of an extra search constraint.

6.2.3. Saving and loading queries

When using complex queries, or one is repeating the same search on annotation files, it is convenient to reuse a query. This is possible in ELAN thanks to the save and load query functionality.

Saving a query

1. Specify a query in the search dialog
2. Either choose Query > Save or click on the save icon in the toolbar.
3. Enter a filename for the active query.
4. Choose save.
Figure 6.8. Saving a query

Loading a query

1. Either choose **Query > Open** or click on the Open icon in the toolbar.
2. Select an existing query from the file dialog.
3. Choose Open.

6.2.4. Exporting the search results

To export the results of a query to a tab-separated file, go through these steps:

1. In the query dialog, select **Query > Export matches**
2. Specify a file name
3. Click on save

An exported file looks as follows:
If you right-click in the table containing the search results, a popup menu appears. Tick the checkboxes to show or hide columns that are related to the found annotations. In the same popup menu you will find the option Export Table as tab-delimited text, which literally saves the displayed result table to a text file, as shown in the example below.

Figure 6.10. Export search results
6.2.5. Search and replace

ELAN offers the possibility to replace all of the found search results. Choose Edit > Replace in the Search Dialog:

Figure 6.11. Search and replace

Then enter the text that should replace the found results and choose OK

6.3. Jumping from the search results to annotations

You can jump from the annotations displayed in the Search-Dialog window to the corresponding annotations in the ELAN window. This option allows you to access other types of information that are linked to the annotations found: to listen to the audio, to watch the video, to view the waveform or to read the annotations on different tiers.

Do the following: In the Search-Dialog window, click on the annotation that you want to jump to. It will be highlighted in blue color. In the ELAN window, the corresponding annotation is automatically accessed.

The screen display should look similar to the following illustration:
6.4. Searching through multiple annotation files

Elan offers an option to search for an expression through multiple files. To access it, go to Search > Search multiple eaf... This will open the following dialog box:
Figure 6.13. Searching through multiple annotation files

In order to perform a multiple file search, go through the following steps:

1. Click on define search domain

2. Add the files and/or directories you want to be searched in the dialog window

3. Click on OK to confirm the selection

4. Enter a search expression, and optionally enable a regular expression and/or case sensitive search.

5. Click on Search. The result screen will appear:

The result window contains the following fields for every found annotation:
• Nr: the order in which the results appear
• File: the file that contains the result
• Before / After: the annotation as found before and after the annotation that matches the search expression
• Annotation: the search result itself
• Begin time, end time, duration: of the annotation unit that was found

Note

It is not possible to restrict the search results to a certain tier or to specify extra structural or temporal constraints.

The displayed search results can be exported to a tab-separated text file as well. The exported files are very similar to that described in Section 6.2.4.

• Just click on Export next to the Search button.
• Enter a filename.
• Select the Save button.

If you click on one of the listed annotations, a new Elan window will be opened, and that annotation unit will be selected. When clicking on another result, the newly opened window is reused.

6.5. Structured search through multiple annotation files

If you want to perform a detailed search over multiple EAF-files, but the options offered by Search multiple EAF (see Section 6.4) are not comprehensive enough, you can use yet another search mode. This allows you to restrict the search domain to certain tiers, to use regular expressions, etc. while examining multiple annotation files at once.

The function can be reached via Search > Structured search multiple eaf... When you click on this option for the first time, you will be asked to define a search domain in the form of one or more .eaf files (exactly like the selection of files as described in Section 6.2.4). The next time you open the Structured search, it uses the last defined search domain. The search window offers the possibility to define a new search domain: click on Define New Domain and select the .eaf files to be searched through.

After defining a search domain for the first time or when you open the Structured search with a search domain from the previous usage, the following window will open:
Figure 6.14. Search eaf files

As you can see there are three tabs offering different kinds of search:

- **Substring Search**: finds all annotations in which the search string occurs.
- **Single Layer Search**: finds all annotations or N-grams in which the search string or regular expression occurs, both case sensitive and insensitive and possibly restricted to one (type of) tier.
- **Multiple Layer Search**: finds annotations in three related tiers. You can use multiple search strings and regular expression and make constraints on duration and time slot as well as constraints on how to search strings are to be combined.

### 6.5.1. Substring Search Tab

This tab offers the simplest search. It just asks for a search string. After entering the search string you can click on **Find** (or press Enter) to start the search process. This will result in a screen like the one below:

Figure 6.15. Substring Search Results

It shows tokens that contain the search string and some tokens in the context printed in italic typeface. The default number of tokens in the context is three on both sides. When the number of hits exceeds the maximum number the window can contain, you can view the rest of the hits by clicking the `<` and `>` button that appear above the list of hits to go back or forward one page. To view an annotation in the timeline view of the main window simply double click it:
Figure 6.16. Hit in transcription

For further investigation of the results the search window offers a context menu that enables you to view the results in other manners and to save the results. To open the context menu right click on one of the results. The menu has the following options:

- **Show Frequency view**: clicking this option shows both frequency and relative frequency (as a percentage) of the tokens found. The relative frequency is relative to the number of hits.

- **Show hit in transcription**: clicking this option shows the transcription in the timeline viewer similar to double clicking an annotation.

- **Show Info balloons**: by clicking this option you enable ELAN to show you information about a token in an info balloon. This balloon will appear when your mouse cursor is hovering over a token. The information shown in the balloon contains:
  - Transcription file
  - Tier name
  - Tier type
  - Participant
  - Position in tier
  - begin time
  - end time
  - duration

- **Context size**: this option offers a submenu that enables you to decrease and increase the context size of the results. Minimum size is 0 and maximum size is 8 tokens.
• **Save hits**: when clicking this option, you will be asked to select a directory and enter a filename. The result is a file that contains the following information per token found:

  – **Annotation**: the annotation token containing the search string.

  – **HitPositionInAnnotation**: the position of the first character of the search string in the annotation.

  – **HitLength**: number of characters in the hit

  – **HitNumberInAnnotation**: if the search string is found more than once in an annotation, this number will give the rank of the hit within the annotation.

  – **AnnotationBeginTime**: the begin time in ms of an annotation containing the search string.

  – **AnnotationEndTime**: the end time in ms of an annotation containing the search string.

  – **HitPositionInTier**: the position of the annotation in a tier.

  – **TierName**: the name of the tier containing the annotation.

  – **TierType**: the type of tier containing the annotation.

  – **LeftContext**: the left context of the annotation.

  – **RightContext**: the right context of the annotation.

  – **TranscriptionName**: the path and filename of the transcription in which the annotation is found.

When you are in the frequency view (Figure 6.17), the context menu has the following options:

• **Show Concordance view**: clicking this option will show the annotation results.

• **Show hit in transcription**: clicking this option shows the transcription in the timeline viewer similar to double clicking an annotation.

• **Save frequency info**: when clicking this option, you will be asked to select a directory and enter a filename. The result is a file that contains the following information:

  – **Annotation**

  – **Percentage**

  – **Count**
6.5.2. Single Layer Search tab

The Single Layer tab offers a more elaborate search than the Substring Search tab. The first thing that is different from the Substring Search tab is that the Single Layer Search tab has a query history. Clicking the < and > button makes the tab respectively go backward and forward one query.

Furthermore, the tab offers different modes to restrict the search. The first mode lets you choose the form of the results. There are three options:

- **Annotation**: the search string is part of or exact match in an annotation.
- **N-gram over annotations**: each element of the search string (elements are divided by spaces) is part of or exact match in one of several consecutive annotations.
- **N-gram within annotation**: each element of the search string (elements are divided by spaces) is part of or exact match in one of several consecutive tokens within one annotation.

The following mode offers the straightforward distinction between **case sensitive** and **case insensitive** search. The third mode lets the user choose if the element of the first mode should contain the search string (substring match), if the element should exactly match the search string (exact match) or if some regular
expression should be used in the match (regular expression). Finally, one can choose to restrict the search to one tier, a tier type or a participant.

**Wildcards and negation**

When you choose an N-gram to be the form of the result, you can use two more options: a wildcard and a negation. The wildcard takes the form of a #-sign. For instance, the search string **the # man** with the mode **N-gram over annotations** would return three annotations per hit: the first annotation contains **the** (or exactly matches that, if the mode **exact match** is chosen), the second annotation may contain anything due to the use of the wildcard and the third annotation contains or exactly matches **man**. If the mode **N-gram within annotation** is chosen, each hit contains one annotation. In this annotation there is a N-gram consisting of three tokens where the first token contains or exactly matches **the**, the second may be anything and the third contains or exactly matches **man**.

If you want to find N-grams where a token matches anything but one string, you can use the negation operator **NOT(...)**, where you can fill in the search string not to be matched on the dots. For instance, the search string **the NOT(strange) man** would return 3-grams in same way as describe above, but the hits where the second annotation or token matches **strange** are left out.

**6.5.3. Multiple Layer Search tab**

The Multiple Layer Search tab houses the most comprehensive search in ELAN. Similar to the Single Layer Search tab a Query History is kept, enabling the user to go back and forward a query by clicking the < and > respectively. The two modes **case sensitive** / **case insensitive** and **substring match** / **exact match** / **regular expression** are also similar to the second tab. The first new element is the **Clear**-button. Clicking this button will clear all data of a query.

The buttons **Minimal Duration** and **Maximal Duration** enables you to constrict the minimal and maximal duration of each result. When you click on one of the buttons, a dialog window appears, e.g.:

**Figure 6.19. Minimal Duration**

Here you can enter the minimal or maximal duration as the total number of milliseconds or in hours:minutes:seconds.milliseconds. A value of 0 milliseconds or 00:00:00.000 yields as undefined. Searching for annotations with a maximum duration being less then the minimum duration is impossible. Hence, entering conflicting values results in an error message saying that the combination is impossible. After entering a correct duration, it will be displayed in the corresponding button.

The buttons **Begin After** and **End Before** give a dialog similar to that of the previous two buttons. They give the possibility to restrict the annotations in the result to begin after a certain time and end before a certain time. Entering a Begin After-time that is greater than the End Before-time or vice versa results in an
error message saying it is impossible. After entering a correct time, it will be displayed in the corresponding button.

**Search string and constraints**

Beneath the buttons discussed above, you will find a table consisting of white and green fields. Search strings are entered in the white fields while a green field between two non-empty white fields must contain a constraint. The fields on one row give the search strings and constraints to be matched by annotations on one tier. The result of having three rows in the query table is that the search engine may find annotations on three tiers as one hit. Furthermore, it is possible to restrict the search to one (type of) tier for each row by choosing the appropriate option in the pull-down menu on the right of each row.

Let us first take a look at search strings and constraints in one row. If you enter two search strings in two white fields separated by a green field, you must fill in that green field i.e. make a constraint. Right clicking on the green field gives a context menu offering the following constraints:

- **= N annotations**: between the annotations containing the two search strings, there must be exactly N annotations.
- **> N annotations**: between the annotations containing the two search strings, there must be more than N annotations.
- **< N annotations**: between the annotations containing the two search strings, there must be less than N annotations.
- **= X milliseconds**: between the annotations containing the two search strings, there must be exactly X milliseconds.
- **> X milliseconds**: between the annotations containing the two search strings, there must be more than X milliseconds.
- **< X milliseconds**: between the annotations containing the two search strings, there must be exactly X milliseconds.
- **No constraints**: there are no constraints.
- **Clear**: clear the current constraint.

When you click on Find and there is an empty constraint between two non-empty search string fields, you will get an error message. You will also get an error message if there is an empty search string field and constraint fields between two non-empty search string fields.

As we saw earlier the search mechanism on this tab has the possibility to construct a query for up to three tiers. Besides the constraints on annotations on a tier, one can also apply constraints on annotations on different tiers. This means that if the search engine has found an annotation that matches a search string on one tier, the engine looks if the search string for another tier can be matched on another tier while considering the constraint that is between the two search strings.

The top down hierarchy of the rows in the query table does not reflect the hierarchy of the tiers in your data. That means, for instance, that search strings and constraints in the upper query table row may be matched by a child tier of the tier that matches search strings and constraints in the middle query table row.

Right clicking the green field between two search strings gives a context menu with the following constraints:

- **Fully aligned**: the begin time and end time of both annotations are the same:

  ![Fully aligned](image)

- **Overlap**: part of both annotations overlap. This includes the other options Fully aligned, Left overlap, Right overlap, Surrounding and Within.
• **Left overlap:** the begin time and end time of the annotation matching the lower search string lie *before* the begin time and end time of the annotation matching the upper search string:

• **Right overlap:** the begin time and end time of the annotation matching the lower search string lie *after* the begin time and end time of the annotation matching the upper search string:

• **Surrounding:** the begin time of the annotation matching the lower search string lies before the begin time of the annotation matching the upper search string and end time of the annotation matching the lower search string lies after the end time of the annotation matching the upper search string:

• **Within:** the begin time of the annotation matching the lower search string lies after the begin time of the annotation matching the upper search string and end time of the annotation matching the lower search string lies before the end time of the annotation matching the upper search string:

• **No overlap:** the begin time of the annotation matching a search string lies after the end time of the annotation matching the other search string:

  or

• **begin time - begin time = X milliseconds:** the begin time of the annotations matching the upper search string must lie exactly X milliseconds before the begin time of the annotation matching the lower search string.

• **begin time - begin time < X milliseconds:** the begin time of the annotations matching the upper search string must lie less than X milliseconds before the begin time of the annotation matching the lower search string.

• **begin time - begin time > X milliseconds:** the begin time of the annotations matching the upper search string must lie more than X milliseconds before the begin time of the annotation matching the lower search string.

• **begin time - end time = X milliseconds:** the begin time of the annotations matching the upper search string must lie exactly X milliseconds before the end time of the annotation matching the lower search string.

• **begin time - end time < X milliseconds:** the begin time of the annotations matching the upper search string must lie less than X milliseconds before the end time of the annotation matching the lower search string.

• **begin time - end time > X milliseconds:** the begin time of the annotations matching the upper search string must lie more than X milliseconds before the end time of the annotation matching the lower search string.

• **end time - begin time = X milliseconds:** the end time of the annotations matching the upper search string must lie exactly X milliseconds before the begin time of the annotation matching the lower search string.

• **end time - begin time < X milliseconds:** the end time of the annotations matching the upper search string must lie less than X milliseconds before the begin time of the annotation matching the lower search string.
• end time - begin time > X milliseconds: the end time of the annotations matching the upper search string must lie more than X milliseconds before the begin time of the annotation matching the lower search string.

• end time - end time = X milliseconds: the end time of the annotations matching the upper search string must lie exactly X milliseconds before the end time of the annotation matching the lower search string.

• end time - end time < X milliseconds: the end time of the annotations matching the upper search string must lie less than X milliseconds before the end time of the annotation matching the lower search string.

• end time - end time > X milliseconds: the end time of the annotations matching the upper search string must lie more than X milliseconds before the end time of the annotation matching the lower search string.

• No constraint: there are no constraints.

• Clear: clear the current constraint.

An example of a Multiple Layer Search with constraints is shown in Figure 6.20:

**Figure 6.20. Multiple Layer query**

Because the search mechanism offers the possibility to search for patterns in three tiers and there are possibly three search strings per tier, the search results also consist of nine elements per hit. Instead of presenting a hit in the form of a table it is presented on one line with indicators for tiers and annotations. Figure 6.20 shows the results of the query above. As you can see the tiers in the result are indicated by #1, #2 and #3 corresponding to the upper, middle and lower query table row respectively. The annotations in a tier are surrounded by vertical bars indicating their start and end.

*Figure 6.20 also illustrates what to do if you would like to use both Exact match and Substring match in one query: use the Regular expression. In places where you would like to have an exact match use the ^ and $ signs to match the beginning and end of a string (e.g. ^of$) otherwise just enter a word for the substring match.*
The figure also show how to use a wildcard to match anything. Instead of using the # as in the Single Layer Search, you can use the regular expression .+ to indicate any character (the dot) one or more times (the plus). See also Appendix A for more on regular expressions. The NOT(...) construction on the other hand can be used in the Multiple Layer Search in the same way as describe in Section 6.5.2.

One final but not less important remark concerns the placing of more and less restrictive search strings. Figure 6.20 shows a very restrictive search string in the upper row: ^n$. The less restrictive, or should we say unrestrictive, search string . is in the middle row. As we saw earlier, the hierarchy of the rows in the query does not reflect the hierarchy in the data. That means that the search string ^n$ could also be placed in the lower row and not affect the outcome of the search. While this is perfectly true, we advise you to place restrictive search strings in the left most field on the upper most row possible and the least restrictive search string in the right most field of the lowest row possible. The reason for this is the order in which the search engine considers the search strings in the query. If it finds a restrictive search string it can filter out all the other possibilities, but if it finds a less restrictive search string it has to consider all the matches of this search string. In the example of Figure 6.20 it is clear that if ^n$ is in the bottom row, the search engine first considers all annotations matching . which is in fact all annotations in the search domain. Because of this, the search takes much more time than if ^n$ was in the upper row.
Chapter 7. Reference guide

In this reference guide, you find concise descriptions of the mouse options (1), the menu item (2), and the shortcut keys (3). In addition, a brief definition of key concepts is provided (4).

7.1. The mouse options

7.1.1. Resizing Viewers

• Click on the up/down arrows in the split-pane to increase/decrease the size of the corresponding Viewer.

• Go with the mouse to the split-pane and move it up/down to increase/decrease the size of the corresponding Viewer.

7.1.2. Rearranging the order of tiers

• Drag a tier label from its place in the Timeline or Interlinear Viewer to any other place in the Timeline Viewer.

7.1.3. Make a tier the active tier

• Double click on a tier label.

• Right click in the Timeline or Interlinear Viewer and choose Active Tier.

7.1.4. Accessing points in time

• Click on any place in the Timeline, Waveform or Annotation Density Viewer to jump to this point in time.

• Click on one of the media controls to go forward/backward in time.

• Click on the timecode box and enter a timecode to jump to this point in time.

7.1.5. Playing a document

• Click on the Play/Pause icon to start or pause the playback.

• Use the Rate slider (in the Controls tab) to increase/decrease the playback rate.

7.1.6. Making a selection

• Click with the mouse on any point in the Timeline or Waveform Viewer, and drag it to another point to select a time interval. Or click on an annotation in the Grid Viewer and drag the mouse to another annotation.

• Click on an annotation in the Timeline or Interlinear Viewer to select it.

7.1.7. Adding/modifying an annotation

• Double-click on an annotation or selection (at about the height of the tier where you want to enter an annotation). The Inline Edit box appears and you can enter the annotation.
7.2. The shortcut keys

7.2.1. File options

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+S</td>
<td>Saves the current project</td>
</tr>
<tr>
<td>CTRL+SHIFT+S</td>
<td>Save as…</td>
</tr>
<tr>
<td>CTRL+SHIFT+ALT+S</td>
<td>Save as template</td>
</tr>
<tr>
<td>CTRL+W</td>
<td>Close the current window</td>
</tr>
<tr>
<td>CTRL+Q</td>
<td>Exit the application</td>
</tr>
<tr>
<td>CTRL+O</td>
<td>Open a document</td>
</tr>
<tr>
<td>CTRL+N</td>
<td>Create a new document</td>
</tr>
<tr>
<td>CTRL+P</td>
<td>Prints the current document</td>
</tr>
<tr>
<td>CTRL+SHIFT+P</td>
<td>Page Setup</td>
</tr>
<tr>
<td>CTRL+ALT+P</td>
<td>Print Preview</td>
</tr>
<tr>
<td>SHIFT+UP</td>
<td>Activate previous window</td>
</tr>
<tr>
<td>SHIFT+DOWN</td>
<td>Activate next window</td>
</tr>
</tbody>
</table>

7.2.2. Playing a document & making selections

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+SPACE</td>
<td>Starts or stops the Media Player</td>
</tr>
<tr>
<td>CTRL+B</td>
<td>Go to the beginning of the video/audio fragment</td>
</tr>
<tr>
<td>CTRL+PAGE UP</td>
<td>Go to the previous scroll view</td>
</tr>
<tr>
<td>SHIFT+LEFT</td>
<td>Go back one second</td>
</tr>
<tr>
<td>CTRL+LEFT</td>
<td>Go back one frame</td>
</tr>
<tr>
<td>CTRL+SHIFT+LEFT</td>
<td>Go back one “pixel” on the annotation density viewer</td>
</tr>
<tr>
<td>CTRL+SHIFT+RIGHT</td>
<td>Go to the next “pixel” on the annotation density viewer</td>
</tr>
<tr>
<td>CTRL+RIGHT</td>
<td>Go to the next frame</td>
</tr>
<tr>
<td>SHIFT+RIGHT</td>
<td>Go to the next second</td>
</tr>
<tr>
<td>CTRL+PAGE DOWN</td>
<td>Go to the next scroll view</td>
</tr>
<tr>
<td>CTRL+E</td>
<td>Go to the end of the media fragment</td>
</tr>
<tr>
<td>CTRL+ALT+R</td>
<td>Switch to predefined playback rate</td>
</tr>
<tr>
<td>CTRL+SHIFT+R</td>
<td>Switch to predefined volume</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Go to time</td>
</tr>
</tbody>
</table>

7.2.3. Working with annotations

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT+N</td>
<td>Opens the Inline Edit box for inserting a new annotation (only available if a time interval or annotation is selected)</td>
</tr>
<tr>
<td>ALT+M</td>
<td>Opens the Inline Edit box for modifying an annotation (only available if an annotation is selected)</td>
</tr>
</tbody>
</table>

1Shortcuts in bold mean that they recently have been changed
<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT+SHIFT+M</td>
<td>Opens the Local Data Category Selection for associating the annotation with</td>
</tr>
<tr>
<td></td>
<td>a data category of the ISO Data Category Registry.</td>
</tr>
<tr>
<td>ALT+Delete</td>
<td>Deletes the value of the selected annotation</td>
</tr>
<tr>
<td>ALT+D</td>
<td>Deletes an annotation (only available if an annotation is selected)</td>
</tr>
<tr>
<td>CTRL+SHIFT+N</td>
<td>New annotation before</td>
</tr>
<tr>
<td>CTRL+SHIFT+N</td>
<td>New annotation after</td>
</tr>
<tr>
<td>CTRL+SHIFT+T</td>
<td>Add new linguistic type</td>
</tr>
<tr>
<td>CTRL+ALT+L</td>
<td>Edit linked file</td>
</tr>
<tr>
<td>CTRL+SHIFT+C</td>
<td>Edit controlled vocabulary</td>
</tr>
<tr>
<td>ALT+LEFT</td>
<td>Go to previous Annotation</td>
</tr>
<tr>
<td>ALT+RIGHT</td>
<td>Go to next Annotation</td>
</tr>
<tr>
<td>ALT+UP</td>
<td>Go annotation upward</td>
</tr>
<tr>
<td>ALT+DOWN</td>
<td>Go annotation downward</td>
</tr>
<tr>
<td>CTRL+T</td>
<td>Add new tier</td>
</tr>
<tr>
<td>CTRL+ALT+T</td>
<td>Delete tier</td>
</tr>
<tr>
<td>CTRL+UP</td>
<td>Set previous tier active</td>
</tr>
<tr>
<td>CTRL+DOWN</td>
<td>Set next tier active</td>
</tr>
<tr>
<td>CTRL+ALT+SHIFT</td>
<td>Show empty slots in multtier viewer</td>
</tr>
<tr>
<td>CTRL+ENTER</td>
<td>Saves the changes made to the Inline Edit box or the Edit annotation box</td>
</tr>
<tr>
<td>ESC</td>
<td>(from within the Inline Edit box or the Edit annotation box): exits the box</td>
</tr>
<tr>
<td></td>
<td>(in all other contexts): deselects a selection</td>
</tr>
<tr>
<td>SHIFT+ENTER</td>
<td>Allows you to switch between the Inline Edit box and the Edit annotation box</td>
</tr>
</tbody>
</table>

### 7.2.4. Copy and paste

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+C</td>
<td>Copy Annotation</td>
</tr>
<tr>
<td>CTRL+ALT+C</td>
<td>Copy Annotation Group</td>
</tr>
<tr>
<td>CTRL+D</td>
<td>Duplicate Annotation</td>
</tr>
<tr>
<td>CTRL+V</td>
<td>Paste Annotation</td>
</tr>
<tr>
<td>CTRL+ALT+V</td>
<td>Paste Annotation Group</td>
</tr>
<tr>
<td>CTRL+SHIFT+V</td>
<td>Paste Annotation Here</td>
</tr>
<tr>
<td>CTRL+ALT+SHIFT+V</td>
<td>Paste Annotation Group Here</td>
</tr>
</tbody>
</table>

### 7.2.5. Working with selections

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SHIFT+SPACE</td>
<td>Play selection</td>
</tr>
<tr>
<td>CTRL+SHIFT+SPACE</td>
<td>Play around selection</td>
</tr>
<tr>
<td>ALT+SHIFT+C</td>
<td>Clear selection</td>
</tr>
<tr>
<td>CTRL+/ or CTRL+SHIFT+K</td>
<td>Move the crosshair to the right or left of the selection</td>
</tr>
</tbody>
</table>
7.2.6. Searching

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+F</td>
<td>Find</td>
</tr>
<tr>
<td>CTRL+SHIFT+F</td>
<td>Search in multiple eaf files</td>
</tr>
</tbody>
</table>

7.2.7. General

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>CTRL+Y</td>
<td>Redo</td>
</tr>
</tbody>
</table>

7.3. Key concepts of ELAN

7.3.1. Annotation file (*.eaf)

An annotation file is the document that contains all the information about tiers (their attributes and dependency relations), annotations and time alignments.

7.3.2. Media file (*.mpg/*.mov, *.wav)

A media file contains the digitized video/audio (e.g. *.mpg) or only the audio (*.wav) data. It determines the time axis to which the annotation file (*.eaf) is linked.

7.3.3. Annotation

An annotation is any type of text (e.g. a transcription, a translation, coding, etc.) that is entered on a tier. It is assigned to a selected time interval of the video/audio file (e.g., to the time interval corresponding to the utterance of a speaker) or to an annotation on another tier (e.g., a translation is assigned to an orthographic transcription).

7.3.4. Tier

A tier is a set of annotations that share the same characteristics, e.g., one tier containing the orthographic transcription, or another tier containing the free translation.

A tier can be ‘independent’ and ‘time-alignable’, in which case it is directly linked to a time interval of the media file (e.g., the ‘orthographic transcription’ tier). Or it can be ‘referring’, in which case it is linked to another tier, its so-called parent tier (e.g., the ‘orthographic transcription’ tier is a parent tier to the ‘free translation’ tier). The referring tier shares its time alignment with its parent tier. Some referring tiers can be assigned to the time axis, but only to an interval that is contained within the interval of their parent annotation.

It is possible to build nested hierarchies, e.g., the ‘orthographic transcription’ tier is the parent tier to a ‘word’ tier, and the ‘word’ tier is the parent tier to a ‘morpheme break’ tier.

Tiers are assigned to linguistic types, which specify certain constraints. The following constraints exist: None (independent, time-alignable tiers), Time Subdivision (the annotation on the referring tier can be subdivided and linked to the time axis), Symbolic Subdivision (the annotation on the referring tier can be subdivided, but not linked to the time axis), Symbolic Association (one annotation on the referring tier corresponds to exactly one annotation on the parent tier).
Appendix A. REGULAR EXPRESSION SEARCH

Brief Background

A regular expression consists of a character string where some characters are given special meaning with regard to pattern matching. Regular expressions have been in use from the early days of computing, and provide a powerful and efficient way to parse, interpret and search and replace text within an application.

Supported Syntax

Table A.1. Characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>The character x</td>
</tr>
<tr>
<td>\</td>
<td>The backslash character</td>
</tr>
<tr>
<td>\0n</td>
<td>The character with octal value 0n (0 &lt;= n &lt;= 7)</td>
</tr>
<tr>
<td>\0nn</td>
<td>The character with octal value 0nn (0 &lt;= n &lt;= 7)</td>
</tr>
<tr>
<td>\0mnn</td>
<td>The character with octal value 0mnn (0 &lt;= m &lt;= 3, 0 &lt;= n &lt;= 7)</td>
</tr>
<tr>
<td>\xhh</td>
<td>The character with hexadecimal value 0xhh</td>
</tr>
<tr>
<td>\uhhhh</td>
<td>The character with hexadecimal value 0xhhhh</td>
</tr>
<tr>
<td>\t</td>
<td>The tab character (\u0009)</td>
</tr>
<tr>
<td>\n</td>
<td>The newline (line feed) character (\u000A)</td>
</tr>
<tr>
<td>\r</td>
<td>The carriage-return character (\u000D)</td>
</tr>
<tr>
<td>\f</td>
<td>The form-feed character (\u000C)</td>
</tr>
<tr>
<td>\a</td>
<td>The alert (bell) character (\u0007)</td>
</tr>
<tr>
<td>\e</td>
<td>The escape character (\u001B)</td>
</tr>
<tr>
<td>\cx</td>
<td>The control character corresponding to x</td>
</tr>
</tbody>
</table>

Table A.2. Character classes

<table>
<thead>
<tr>
<th>Character class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[abc]</td>
<td>a, b, or c (simple class)</td>
</tr>
<tr>
<td>[^abc]</td>
<td>Any character except a, b, or c (negation)</td>
</tr>
<tr>
<td>[a-zA-Z]</td>
<td>a through Z or A through Z, inclusive (range)</td>
</tr>
<tr>
<td>[a-d[m-p]]</td>
<td>a through d or m through p: [a-dm-p] (union)</td>
</tr>
<tr>
<td>[a-zA-Z&amp;[def]]</td>
<td>d, e, or f (intersection)</td>
</tr>
<tr>
<td>[a-zA-Z&amp;[^bc]]</td>
<td>a through z, except for b and c: [ad-z] (subtraction)</td>
</tr>
<tr>
<td>[a-zA-Z&amp;[^m-p]]</td>
<td>a through z, and not m through p: [a-1q-z] (subtraction)</td>
</tr>
</tbody>
</table>

Table A.3. Predefined character classes

| Source: http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html |
REGULAR EXPRESSION SEARCH

<table>
<thead>
<tr>
<th>\d</th>
<th>Any character (may or may not match line terminators [<a href="http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#lt">http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#lt</a>])</th>
</tr>
</thead>
<tbody>
<tr>
<td>\D</td>
<td>A digit: [0-9]</td>
</tr>
<tr>
<td>\s</td>
<td>A non-digit: [^0-9]</td>
</tr>
<tr>
<td>\s</td>
<td>A whitespace character: [ \t\n\x0B\f\r]</td>
</tr>
<tr>
<td>\S</td>
<td>A non-whitespace character: [^\s]</td>
</tr>
<tr>
<td>\w</td>
<td>A word character: [a-zA-Z_0-9]</td>
</tr>
<tr>
<td>\W</td>
<td>A non-word character: [^\w]</td>
</tr>
</tbody>
</table>

Table A.4. POSIX character classes (US-ASCII only)

| \p{Lower} | A lower-case alphabetic character: [a-z]                             |
| \p{Upper} | An upper-case alphabetic character: [A-Z]                            |
| \p{ASCII} | All ASCII: [\x00-\x7F]                                             |
| \p{Alpha} | An alphabetic character: [\p{Lower}\p{Upper}]                      |
| \p{Digit} | A decimal digit: [0-9]                                              |
| \p{Alnum} | An alphanumeric character: [\p{Alpha}\p{Digit}]                     |
| \p{Punct} | Punctuation: One of !"#$%&'()*+,-/:;?@\^\_`{|}~                     |
| \p{Graph} | A visible character: [\p{Alnum}\p{Punct}]                          |
| \p{Print} | A printable character: [\p{Graph}]                                |
| \p{Blank} | A space or a tab: [ \t]                                           |
| \p{Cntrl} | A control character: [\x00-\x1F\x7F]                               |
| \p{XDigit} | A hexadecimal digit: [0-9a-fA-F]                                    |
| \p{Space} | A whitespace character: [ \t\n\x0B\f\r]                            |

Table A.5. Classes for Unicode blocks and categories

| \p{InGreek} | A character in the Greek block (simple block [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#ubc]) |
| \p{Lu} | An uppercase letter (simple category [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#ubc]) |
| \p{Sc} | A currency symbol                                                   |
| \P{InGreek} | Any character except one in the Greek block (negation)             |
| [\p{L}&&[^\p{Lu}]] | Any letter except an uppercase letter (subtraction) |

Table A.6. Boundary matchers

| ^ | The beginning of a line                                            |
| $ | The end of a line                                                   |
| \b | A word boundary                                                    |
| \B | A non-word boundary                                                |
| \A | The beginning of the input |
| \G | The end of the previous match |
| \Z | The end of the input but for the final terminator [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#lt], if any |
| \z | The end of the input |

**Table A.7. Greedy quantifiers**

| X? | X, once or not at all |
| X* | X, zero or more times |
| X+ | X, one or more times |
| X\{ n \} | X, exactly n times |
| X\{ n, \} | X, at least n times |
| X\{ n, m \} | X, at least n but not more than m times |

**Table A.8. Reluctant quantifiers**

| X?? | X, once or not at all |
| X*? | X, zero or more times |
| X+? | X, one or more times |
| X\{ n \}? | X, exactly n times |
| X\{ n, \}? | X, at least n times |
| X\{ n, m \}? | X, at least n but not more than m times |

**Table A.9. Possessive quantifiers**

| X?+ | X, once or not at all |
| X*+ | X, zero or more times |
| X++ | X, one or more times |
| X\{ n \}+ | X, exactly n times |
| X\{ n, \}+ | X, at least n times |
| X\{ n, m \}+ | X, at least n but not more than m times |

**Table A.10. Logical operators**

| XY | X followed by Y |
| X | Y | Either X or Y |
| (X) | X, as a capturing group [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#cg] |

**Table A.11. Back references**

| \n | Whatever the $n^{th}$ capturing group [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#cg] matched |

**Table A.12. Quotation**

| \ | Nothing, but quotes the following character |
Backslashes, escapes, and quoting

The backslash character (\') serves to introduce escaped constructs, as defined in the table above, as well as to quote characters that otherwise would be interpreted as unescaped constructs. Thus the expression \ matches a single backslash and { matches a left brace.

It is an error to use a backslash prior to any alphabetic character that does not denote an escaped construct; these are reserved for future extensions to the regular-expression language. A backslash may be used prior to a non-alphabetic character regardless of whether that character is part of an unescaped construct.


The string literal "\(hello\)" is illegal and leads to a compile-time error; in order to match the string (hello) the string literal "\\(hello\\)" must be used.

A.1. Character Classes

Character classes may appear within other character classes, and may be composed by the union operator (implicit) and the intersection operator (&&). The union operator denotes a class that contains every character that is in at least one of its operand classes. The intersection operator denotes a class that contains every character that is in both of its operand classes.

The precedence of character-class operators is as follows, from highest to lowest:

<table>
<thead>
<tr>
<th>Precedence</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Literal escape</td>
<td>\x</td>
</tr>
<tr>
<td>2</td>
<td>Grouping</td>
<td>[...]</td>
</tr>
<tr>
<td>3</td>
<td>Range</td>
<td>a-z</td>
</tr>
<tr>
<td>4</td>
<td>Union</td>
<td>[a-e][i-u]</td>
</tr>
<tr>
<td>5</td>
<td>Intersection</td>
<td>[a-z&amp;&amp;[aeiou]]</td>
</tr>
</tbody>
</table>

Note that a different set of metacharacters are in effect inside a character class than outside a character class. For instance, the regular expression . loses its special meaning inside a character class, while the expression - becomes a range forming metacharacter.
A.2. Line terminators

A line terminator is a one- or two-character sequence that marks the end of a line of the input character sequence. The following are recognized as line terminators:

- A newline (line feed) character (\n),
- A carriage-return character followed immediately by a newline character (\r\n),
- A standalone carriage-return character (\r),
- A next-line character (\u0085),
- A line-separator character (\u2028), or
- A paragraph-separator character (\u2029).

If UNIX_LINES [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#UNIX_LINES] mode is activated, then the only line terminators recognized are newline characters.

The regular expression . matches any character except a line terminator unless the DOTALL [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#DOTALL] flag is specified.

By default, the regular expressions ^ and $ ignore line terminators and only match at the beginning and the end, respectively, of the entire input sequence. If MULTILINE [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#MULTILINE] mode is activated then ^ matches at the beginning of input and after any line terminator except at the end of input. When in MULTILINE [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#MULTILINE] mode $ matches just before a line terminator or the end of the input sequence.

A.3. Groups and capturing

Capturing groups are numbered by counting their opening parentheses from left to right. In the expression ((A)(B(C))) for example, there are four such groups:

<table>
<thead>
<tr>
<th>Group</th>
<th>Subexpression</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>(A) (B (C) )</td>
</tr>
<tr>
<td>2</td>
<td>(A)</td>
</tr>
<tr>
<td>3</td>
<td>(B (C) )</td>
</tr>
<tr>
<td>4</td>
<td>(C)</td>
</tr>
</tbody>
</table>

Group zero always stands for the entire expression.

Capturing groups are so named because, during a match, each subsequence of the input sequence that matches such a group is saved. The captured subsequence may be used later in the expression, via a back reference, and may also be retrieved from the matcher once the match operation is complete.

The captured input associated with a group is always the subsequence that the group most recently matched. If a group is evaluated a second time because of quantification then its previously-captured value, if any, will be retained if the second evaluation fails. Matching the string "aba" against the expression (a(b)?)+, for example, leaves group two set to "b". All captured input is discarded at the beginning of each match.

Groups beginning with (? are pure, non-capturing groups that do not capture text and do not count towards the group total.

Unicode support

This class follows Unicode Technical Report #18: Unicode Regular Expression Guidelines [http://www.unicode.org/unicode/reports/tr18/], implementing its second level of support through with a slightly different concrete syntax.
Unicode escape sequences such as \u2014 in Java source code are processed as described in ?3.3 [http://java.sun.com/docs/books/jls/second_edition/html/lexical.doc.html#100850] of the Java Language Specification. Such escape sequences are also implemented directly by the regular-expression parser so that Unicode escapes can be used in expressions that are read from files or from the keyboard. Thus the strings "\u2014" and "\u2014", while not equal, compile into the same pattern, which matches the character with hexadecimal value 0x2014.

Unicode blocks and categories are written with the \p and \P constructs as in Perl. \p{prop} matches if the input has the property prop, while \P{prop} does not match if the input has that property. Blocks are specified with the prefix In, as in InMongolian. Categories may be specified with the optional prefix Is: Both \p{L} and \p{IsL} denote the category of Unicode letters. Blocks and categories can be used both inside and outside of a character class.

The supported blocks and categories are those of The Unicode Standard, Version 3.0 [http://www.unicode.org/unicode/standard/standard.html]. The block names are those defined in Chapter 14 and in the file Blocks-3.txt [http://www.unicode.org/Public/3.0-Update/Blocks-3.txt] of the Unicode Character Database [http://www.unicode.org/Public/3.0-Update/UnicodeCharacterDatabase-3.0.0.html] except that the spaces are removed; "Basic Latin", for example, becomes "BasicLatin". The category names are those defined in table 4-5 of the Standard (p. 88), both normative and informative.

### A.4. Comparison to Perl 5

Perl constructs not supported by this class:

- The conditional constructs (?{X}) and (?{condition}X|Y),
- The embedded code constructs {?{code}} and {?{code}},
- The embedded comment syntax (?#comment), and
- The preprocessing operations \l \u, \L, and \U.

Constructs supported by this class but not by Perl:

- Possessive quantifiers, which greedily match as much as they can and do not back off, even when doing so would allow the overall match to succeed.
- Character-class union and intersection as described above [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html#cc].

Notable differences from Perl:

In Perl, \1 through \9 are always interpreted as back references; a backslash-escaped number greater than 9 is treated as a back reference if at least that many subexpressions exist, otherwise it is interpreted, if possible, as an octal escape. In this class octal escapes must always begin with a zero. In this class, \1 through \9 are always interpreted as back references, and a larger number is accepted as a back reference if at least that many subexpressions exist at that point in the regular expression, otherwise the parser will drop digits until the number is smaller or equal to the existing number of groups or it is one digit.

Perl uses the g flag to request a match that resumes where the last match left off. This functionality is provided implicitly by the Matcher [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Matcher.html] class: Repeated invocations of the find [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Matcher.html#find%28%29] method will resume where the last match left off, unless the matcher is reset.

In Perl, embedded flags at the top level of an expression affect the whole expression. In this class, embedded flags always take effect at the point at which they appear, whether they are at the top level or within a group; in the latter case, flags are restored at the end of the group just as in Perl.

Perl is forgiving about malformed matching constructs, as in the expression *a, as well as dangling brackets, as in the expression abc], and treats them as literals. This class also accepts dangling brackets but is strict
about dangling metacharacters like +, ?, and *, and will throw a PatternSyntaxException [http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/PatternSyntaxException.html] if it encounters them.